$1900 to fix my "SERVICE BRAKE SYSTEM" message? - Chevy SSR Forum
 
LinkBack Thread Tools Display Modes
post #1 of 26 (permalink) Old 04-26-2010, 07:36 AM Thread Starter
Senior Member
 
Join Date: Feb 2005
Posts: 740


$1900 to fix my "SERVICE BRAKE SYSTEM" message?

Last week I started getting a "SERVICE BRAKE SYSTEM" message on my DIC. The dealer just called, it's 1900 to fix.

WTF?
dougnc is offline  
Sponsored Links
Advertisement
 
post #2 of 26 (permalink) Old 04-26-2010, 07:40 AM
Senior Member
 
Join Date: Jul 2005
Location: Belvidere, New Jersey
Posts: 4,489


My SSR:
Sadly sold '03 RED vin1337, '06(lastoneinblack) vin 24107..Sadly sold '04UV,'05SILVER,'06PACBLU FPR
what are they changing ? Maybe ABS wheel sensors, or just rotors and pads front and rear ?
ssrtruck is offline  
post #3 of 26 (permalink) Old 04-26-2010, 07:58 AM Thread Starter
Senior Member
 
Join Date: Feb 2005
Posts: 740


Quote:
Originally Posted by ssrtruck View Post
what are they changing ? Maybe ABS wheel sensors, or just rotors and pads front and rear ?
No, all that stuff is fine.

GM is coming out with a new computer module on May 5, and we're all supposed to swap ours out.
dougnc is offline  
post #4 of 26 (permalink) Old 04-26-2010, 08:00 AM
SSR Pit Crew
Lifetime Supporting Member
 
MnMsToy's Avatar
 
Join Date: Mar 2009
Location: Western, NC
Posts: 9,920


Glad I have an extended warranty
MnMsToy is offline  
post #5 of 26 (permalink) Old 04-26-2010, 10:44 AM
SSR Pit Crew
Lifetime Supporting Member
 
SSR290's Avatar
 
Join Date: Oct 2003
Location: Sayre Pennsylvania
Posts: 1,029


My SSR:
Silver/Blue #23810
Question Service brake system

Last summer had "SERVICE BRAKE SYSTEM" pop up on the DIC last summer.
A lot of other lights and messages came later.

Turned out to be the Ignition Switch.

A lot less than $1900.

Diamond Jim
SSR290 is offline  
post #6 of 26 (permalink) Old 04-26-2010, 11:28 AM
Senior Member
 
ChuckDuck's Avatar
 
Join Date: Dec 2005
Location: Houston , Texas
Posts: 2,049


My SSR:
2003 Black vin 2620
Sounds like what happened to mine. Check out this thread for some info
Broke anti brake module

The last post has a link for rebuilding the abs, it can be rebuildt without having to reprogram it , so you can avoid the dealership.
ChuckDuck is offline  
post #7 of 26 (permalink) Old 04-27-2010, 06:29 AM Thread Starter
Senior Member
 
Join Date: Feb 2005
Posts: 740


Well, GM is pretty firm that this module must be replaced.
dougnc is offline  
post #8 of 26 (permalink) Old 04-27-2010, 06:43 AM
Highest Mileage Moderator
Lifetime Supporting Member
 
WOW_FCTR's Avatar
 
Join Date: Mar 2003
Location: Sicklerville, NJ
Posts: 10,950


My SSR:
Black, '03, 1sb, #1256 and '05
Quote:
Originally Posted by dougnc View Post
Well, GM is pretty firm that this module must be replaced.
PM wingrider...a master GM tech who will give it to you straight.

2003 Black SSR #1256 1sb
100K miles 02/04/07
150K miles 10/22/08
200K 6/9/11
225K 2/1/13
235K 10/5/13
2005 SSR +50K miles driven 7/1/16
WOW_FCTR is offline  
post #9 of 26 (permalink) Old 04-29-2010, 05:25 PM
Member
 
Join Date: Mar 2010
Location: Albuquerque, NM
Posts: 6


It's a long shot but you might try checking this fuse (highlighted with the red box)


phy911 is offline  
post #10 of 26 (permalink) Old 05-14-2010, 12:09 PM
Highest Mileage Moderator
Lifetime Supporting Member
 
WOW_FCTR's Avatar
 
Join Date: Mar 2003
Location: Sicklerville, NJ
Posts: 10,950


My SSR:
Black, '03, 1sb, #1256 and '05
Quote:
Originally Posted by dougnc View Post
Last week I started getting a "SERVICE BRAKE SYSTEM" message on my DIC. The dealer just called, it's 1900 to fix.

WTF?
I just had this message pop up

I had done something different than I normally do.
I was getting gas and I turned the key to ACC position to listen to the radio while it was filling up. I stepped on the brake a much longer time than I would normally when I started it up and I got this message.

I drove about 3 miles, parked, turned the truck off and then turned it back on. The message is gone. I am making a 300+ mile trip this afternoon....so I am going to forget I ever had this message well until it shows up again

2003 Black SSR #1256 1sb
100K miles 02/04/07
150K miles 10/22/08
200K 6/9/11
225K 2/1/13
235K 10/5/13
2005 SSR +50K miles driven 7/1/16
WOW_FCTR is offline  
post #11 of 26 (permalink) Old 05-14-2010, 12:14 PM
Slingshot Rules!
Lifetime Supporting Member
 
DOOPHUS's Avatar
 
Join Date: Nov 2006
Location: The Southern Banks of The Rillito River
Posts: 46,752


My SSR:
Slingshot Yellow VIN 20778 Born 05 May 2005 (05/05/05)
Send a message via Yahoo to DOOPHUS
Quote:
Originally Posted by WOW_FCTR View Post
I am making a 300+ mile trip this afternoon....so I am going to forget I ever had this message well until it shows up again
What message, WOW?

! ! ! ! ! !

Just Say NO To BBQ
DOOPHUS is offline  
post #12 of 26 (permalink) Old 05-14-2010, 12:18 PM
Highest Mileage Moderator
Lifetime Supporting Member
 
WOW_FCTR's Avatar
 
Join Date: Mar 2003
Location: Sicklerville, NJ
Posts: 10,950


My SSR:
Black, '03, 1sb, #1256 and '05
Quote:
Originally Posted by DOOPHUS View Post
What message, WOW?

! ! ! ! ! !
"Service Brake System" I'm going to PM Bill (wingrider) next week if I see it again...

2003 Black SSR #1256 1sb
100K miles 02/04/07
150K miles 10/22/08
200K 6/9/11
225K 2/1/13
235K 10/5/13
2005 SSR +50K miles driven 7/1/16
WOW_FCTR is offline  
post #13 of 26 (permalink) Old 05-14-2010, 12:37 PM
Senior Member
 
jimbo53's Avatar
 
Join Date: Jan 2008
Location: Broken Arrow Ok.
Posts: 435


Me also Glad I have an extended warranty it would just paid for itself?
jimbo53 is offline  
post #14 of 26 (permalink) Old 05-14-2010, 01:11 PM
also known as "3936"
Supporting Member
 
XSELER8's Avatar
 
Join Date: Jun 2006
Location: Lake Worth, Fl / Montco, Pa
Posts: 36,496


My SSR:
Currently living in Texas
Quote:
Originally Posted by dougnc View Post
No, all that stuff is fine.

GM is coming out with a new computer module on May 5, and we're all supposed to swap ours out.
I'll believe it when it's in my R.

XSELER8 is offline  
post #15 of 26 (permalink) Old 05-17-2010, 07:12 AM
Highest Mileage Moderator
Lifetime Supporting Member
 
WOW_FCTR's Avatar
 
Join Date: Mar 2003
Location: Sicklerville, NJ
Posts: 10,950


My SSR:
Black, '03, 1sb, #1256 and '05
Quote:
Originally Posted by WOW_FCTR View Post
"Service Brake System" I'm going to PM Bill (wingrider) next week if I see it again...
I drove a couple hundred miles this weekend and did not see the message again.

2003 Black SSR #1256 1sb
100K miles 02/04/07
150K miles 10/22/08
200K 6/9/11
225K 2/1/13
235K 10/5/13
2005 SSR +50K miles driven 7/1/16
WOW_FCTR is offline  
post #16 of 26 (permalink) Old 05-17-2010, 07:39 AM
Senior Member
Supporting Member
 
Beach potato's Avatar
 
Join Date: Mar 2006
Location: Cocoa Beach, Florida
Posts: 5,533


My SSR:
2006 Racy Aqua Blur 6spd Chromed/SS front Tuned/ported by Jeremy
I'm wondering about this too

Quote:
Originally Posted by XSELER8 View Post
I'll believe it when it's in my R.

...

Beach potato is offline  
post #17 of 26 (permalink) Old 05-17-2010, 07:49 AM
Gone to the Dogs...
Lifetime Supporting Member
 
pugpower's Avatar
 
Join Date: May 2009
Location: Shippensburg, PA
Posts: 228


My SSR:
'05 Slingshot 6 spd 4.10 Rear Magnaflow Performance Exhaust K & N Air PCM Performance Tune
Quote:
Originally Posted by dougnc View Post
No, all that stuff is fine.

GM is coming out with a new computer module on May 5, and we're all supposed to swap ours out.
Recall?? (i.e. no cost to owner??).........

I'm never lost as long as I'm not outta gas!!

SSR Slingshot Yellow 6.0 liter 6 speed
Triumph Rocket III 2300cc Cruiser
pugpower is offline  
post #18 of 26 (permalink) Old 05-31-2010, 10:03 PM
SSR Pit Crew
Lifetime Supporting Member
 
rkenly's Avatar
 
Join Date: Aug 2007
Location: CA High Desert
Posts: 492


My SSR:
06 Blue/Black - 1SS
happened to me today

I had this message pop up today. Turned off ignition 3 different times during the day (drove 460 miles) and it still would come on within a few minutes every time.

Has the new computer module come out yet?

If it is the ign switch, how does one tell if it is bad?

Inquiring minds... (or mindless)

>>>Rod<<<
rkenly is offline  
post #19 of 26 (permalink) Old 06-01-2010, 07:03 AM
Highest Mileage Moderator
Lifetime Supporting Member
 
WOW_FCTR's Avatar
 
Join Date: Mar 2003
Location: Sicklerville, NJ
Posts: 10,950


My SSR:
Black, '03, 1sb, #1256 and '05
Quote:
Originally Posted by WOW_FCTR View Post
I drove a couple hundred miles this weekend and did not see the message again.
My message has not reappeared (hope I didn't jinx myself )

2003 Black SSR #1256 1sb
100K miles 02/04/07
150K miles 10/22/08
200K 6/9/11
225K 2/1/13
235K 10/5/13
2005 SSR +50K miles driven 7/1/16
WOW_FCTR is offline  
post #20 of 26 (permalink) Old 06-01-2010, 07:27 AM
Senior Member
 
BluDragon's Avatar
 
Join Date: Jul 2007
Location: Scranton Pa
Posts: 757


My SSR:
'05 Aqua Blur
Last year coming back from the Harolds meet and greet, we had a ABS Break system failure and it fried the main computer too! Stop the truck dead in it's tracks. The dealer replaced the main computer and the ABS module under the factory extended warrantee that all our trucks have (5 year - 80,000 mile powertrain). However, the dealer felt the ABS/break system was the cause for the main computer melt-down, he wrote up the repair as if the main computer was the issue and it fried the ABS system. This way it was covered by the warrantee.

So word of caution... this might be related and it could take your truck off-line completely. Make sure you have your AAA towing up to date!

Michael
BluDragon is offline  
post #21 of 26 (permalink) Old 06-29-2010, 10:29 AM
Highest Mileage Moderator
Lifetime Supporting Member
 
WOW_FCTR's Avatar
 
Join Date: Mar 2003
Location: Sicklerville, NJ
Posts: 10,950


My SSR:
Black, '03, 1sb, #1256 and '05
Quote:
Originally Posted by WOW_FCTR View Post
I drove a couple hundred miles this weekend and did not see the message again.
Quote:
Originally Posted by WOW_FCTR View Post
My message has not reappeared (hope I didn't jinx myself )
I just got the Service Brake message and could not shift into Drive.

I shut off the vehicle and wiggled my keys....the message went away and I could shift again


Might be time for me to replace my ignition switch....

2003 Black SSR #1256 1sb
100K miles 02/04/07
150K miles 10/22/08
200K 6/9/11
225K 2/1/13
235K 10/5/13
2005 SSR +50K miles driven 7/1/16
WOW_FCTR is offline  
post #22 of 26 (permalink) Old 06-29-2010, 11:28 AM
Senior Member
 
ChuckDuck's Avatar
 
Join Date: Dec 2005
Location: Houston , Texas
Posts: 2,049


My SSR:
2003 Black vin 2620
Quote:
Originally Posted by WOW_FCTR View Post
I just got the Service Brake message and could not shift into Drive.

I shut off the vehicle and wiggled my keys....the message went away and I could shift again


Might be time for me to replace my ignition switch....
My '03 had the Service Brake message come and go , left me worried that the ABS would fail when I needed it so I had it fixed.
ChuckDuck is offline  
post #23 of 26 (permalink) Old 06-29-2010, 12:56 PM
Highest Mileage Moderator
Lifetime Supporting Member
 
WOW_FCTR's Avatar
 
Join Date: Mar 2003
Location: Sicklerville, NJ
Posts: 10,950


My SSR:
Black, '03, 1sb, #1256 and '05
Quote:
Originally Posted by ChuckDuck View Post
My '03 had the Service Brake message come and go , left me worried that the ABS would fail when I needed it so I had it fixed.
So yours was just the ignition switch?

2003 Black SSR #1256 1sb
100K miles 02/04/07
150K miles 10/22/08
200K 6/9/11
225K 2/1/13
235K 10/5/13
2005 SSR +50K miles driven 7/1/16
WOW_FCTR is offline  
post #24 of 26 (permalink) Old 11-19-2010, 10:38 PM
Private SSR Investigator
Lifetime Supporting Member
 
Cash's Avatar
 
Join Date: Aug 2008
Location: Kamloops, British Columbia
Posts: 11,596


My SSR:
"Kate" a Haughty Redhead, '06 Redline FPR 6 spd. #23333 Build Date 2/16/06
Garage
So how did everyone make out with this?
Dougnc- Did you replace the module?
Wow_fctr - Did you just replace the switch?
Rkenly? - Yours go away?
ChuckDuck- Your fix was?
Mine has been doing this off and on. I've put her to bed for a few months to rest up and get better on her own.


"Such are the Vagaries of Life"
Ah, I'm Just Truckin' With Ya!
Cash is online now  
post #25 of 26 (permalink) Old 11-21-2010, 07:49 AM
SSR Pit Crew
Lifetime Supporting Member
 
rkenly's Avatar
 
Join Date: Aug 2007
Location: CA High Desert
Posts: 492


My SSR:
06 Blue/Black - 1SS
abs unit

I finally took my R into another mechanic. He has done all the testing on grounds and everything else. He indicated that everything points to the ABS module.

SO I have it on order - coming from the east coast - should be here day after Thanksgiving.

>>>Rod<<<
rkenly is offline  
post #26 of 26 (permalink) Old 11-21-2010, 08:36 AM
SSR Pit Crew
Lifetime Supporting Member
 
MnMsToy's Avatar
 
Join Date: Mar 2009
Location: Western, NC
Posts: 9,920


Thumbs up

Quote:
Originally Posted by Cash View Post
So how did everyone make out with this?
Dougnc- Did you replace the module?
Wow_fctr - Did you just replace the switch?
Rkenly? - Yours go away?
ChuckDuck- Your fix was?
Mine has been doing this off and on. I've put her to bed for a few months to rest up and get better on her own.
Yea, we would all like to know.
MnMsToy is offline  
Sponsored Links
Advertisement
 
Reply

  Chevy SSR Forum > SSR Discussion > SSR Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy SSR Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome