Engine Temperature Guage - Chevy SSR Forum
 4Likes
  • 2 Post By Dicktator
  • 2 Post By James Dean
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 03-01-2017, 08:48 PM Thread Starter
Member
 
Join Date: Mar 2017
Posts: 16


Engine Temperature Guage

2005 SSR 6.0

My engine temperature gage on the dash has quit working. The needle is hanging straight down and not responding as the vehicle heats up. Anybody else have this problem. Possible Causes ??Possible Fixes ???

Big thanks

Layne12gun
Layne12gun is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 03-01-2017, 11:28 PM
Cantankerous SSR CaretakR
Lifetime Supporting Member
 
river_rat's Avatar
 
Join Date: Aug 2007
Location: SE Texas
Posts: 1,571


My SSR:
2005 Slingshot Yellow (O-YLR)
Most likely a bad stepper motor. Does it sweep like the rest of the gauges when you start your truck? Stepper motors are a common problem with GM dash clusters. Numerous repair shops everywhere can fix or several fanatics can help depending upon your location. Or easy to repair yourself if you're handy with a soldering iron. You'll want to replace all 5 as well as the illumination bulbs if you repair it. Do an Internet search on GM cluster repair for more info.
river_rat is offline  
post #3 of 10 (permalink) Old 03-02-2017, 12:48 AM
hayling island uk
Supporting Member
 
alan's Avatar
 
Join Date: Aug 2012
Posts: 155


hi keep starting car and switching it of will give you a temporary fix
alan is offline  
 
post #4 of 10 (permalink) Old 03-02-2017, 06:51 AM
SSR Pit Crew
Lifetime Supporting Member
 
Dicktator's Avatar
 
Join Date: Nov 2006
Location: Clearwater, Fl
Posts: 9,449


My SSR:
04 Silver/Race Stripes 4:10 gears tuned at 130mph lowered 2"
OEM stepper motors go bad, C5-168

Upgraded stepper motors X27-168

Just change all 5, all good.

Cluster removal on SSR How to Library.

Link: https://onedrive.live.com/?id=3EF39D...F39D9F5ADCE5E5


Dicktator
Jerry and alan like this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dicktator is online now  
post #5 of 10 (permalink) Old 03-03-2017, 06:07 PM Thread Starter
Member
 
Join Date: Mar 2017
Posts: 16


Quote:
Originally Posted by river_rat View Post
Most likely a bad stepper motor. Does it sweep like the rest of the gauges when you start your truck? Stepper motors are a common problem with GM dash clusters. Numerous repair shops everywhere can fix or several fanatics can help depending upon your location. Or easy to repair yourself if you're handy with a soldering iron. You'll want to replace all 5 as well as the illumination bulbs if you repair it. Do an Internet search on GM cluster repair for more info.
No it does not move at all when the engine starts hangs straight down.
Layne12gun is offline  
post #6 of 10 (permalink) Old 03-03-2017, 06:35 PM
Jim & Sherrie
Lifetime Supporting Member
 
James Dean's Avatar
 
Join Date: Mar 2006
Location: Kittanning,Pa
Posts: 25,037


My SSR:
2004 Smokin' Asphalt #11150
Garage
Quote:
Originally Posted by Layne12gun View Post
No it does not move at all when the engine starts hangs straight down.
Bad stepper motor or the needle came loose and is just hanging !!!!!!!! If you go though the trouble of taking the cluster out you should change the stepper motors in my opinion.
DOOPHUS and Guzzi Guy like this.

Jim & Sherrie

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JAMES DEAN
"Blessings can be big or small, but be sure to count them all
James Dean is offline  
post #7 of 10 (permalink) Old 03-04-2017, 08:37 AM
SSR Pit Crew
Lifetime Supporting Member
 
Dicktator's Avatar
 
Join Date: Nov 2006
Location: Clearwater, Fl
Posts: 9,449


My SSR:
04 Silver/Race Stripes 4:10 gears tuned at 130mph lowered 2"
Quote:
Originally Posted by James Dean View Post
Bad stepper motor or the needle came loose and is just hanging !!!!!!!! If you go though the trouble of taking the cluster out you should change the stepper motors in my opinion.
I agree!!

Dicktator


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dicktator is online now  
post #8 of 10 (permalink) Old 03-05-2017, 08:07 PM Thread Starter
Member
 
Join Date: Mar 2017
Posts: 16


Thanks guys and gals for the info. Will try it next day off
Layne12gun is offline  
post #9 of 10 (permalink) Old 03-18-2017, 09:32 PM Thread Starter
Member
 
Join Date: Mar 2017
Posts: 16


You guys were spot on . Bad stepper motor. Got the dash apart thanks to the forum tutorial and sent the cluster off to be rebuilt. Be good as new next week Thanks Guys . Layne12gun
Layne12gun is offline  
post #10 of 10 (permalink) Old 03-18-2017, 10:11 PM
Daily Driver
Lifetime Supporting Member
 
xoxoxoBruce's Avatar
 
Join Date: Nov 2006
Location: DelCo, PA
Posts: 5,918


My SSR:
'06- Silver/Copper- 121421
Of course Layne12gun, would we lie to you our oldest and dearest friend?

SSR Fanatics.....Knowledgeable friends, just a click away.
xoxoxoBruce is online now  
Sponsored Links
Advertisement
 
Reply

  Chevy SSR Forum > SSR Discussion > SSR Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy SSR Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome