Chevy SSR Forum - View Profile: Mike in AZ

Mike in AZ Mike in AZ is offline

Supporting SSR Hobbyist

  Visitor Messages

Showing Visitor Messages 1 to 10 of 17
  1. roosters d
    05-23-2016 07:18 PM - permalink
    roosters d
    Mike,
    Brand new to the SSR community. I saw your message on parting out a 2005 about the ashtray. I too need your stainless steel fix for mine (along with a list of other upgrades). where do I get this "fix"? Thanks
  2. AlbertFlasher
    05-23-2016 09:36 AM - permalink
    AlbertFlasher
    Mike,
    Is it possible to replace damaged transmission fluid lines with braided? If so, can you supply a kit or tell what and where to buy from?

    Thanks,
    Wally

    Newalla Ok...
  3. Ghostrider
    05-08-2016 03:33 PM - permalink
    Ghostrider
    Do you sell the kit Mike for the ashtray?
    Mine's broken now

    please email me at sales@GRCustoms.com

    Thanks!

    AA
  4. dave rasmussen
    04-19-2016 02:23 PM - permalink
    dave rasmussen
    Please put me on the list.

    Maybe they will done about the same time as the other parts.

    Hope you are doing well.

    Dave
  5. Larry Chapin
    03-26-2016 12:05 PM - permalink
    Larry Chapin
    I am in AZ for a week how do I find Mike @ your work place? My number in Mesa 480-373-2136 Tanks Larry
  6. Mike in AZ
    10-26-2015 07:12 AM - permalink
    Mike in AZ
    I do not monitor this message box. If you need to contact me, please use my email address. Mike@simple-engineering.com

    Thanks,

    Mike
  7. dannygolf
    10-11-2015 06:07 PM - permalink
    dannygolf
    Hi Mike,
    I posted about my 05 overheating last week on the forum and have not had time to look into it until today. This is what i found, I unplugged the harness going to the fan and made a switch like you described in a post to me and the fan will run on low and high. so i heated the engine up to running temp and checked the other side of the harness unplugged from the fan and found fire to both hot wires with the ground (black) wire, then hooked harness back together and fan will not work, why am i loosing power when i hook the harness together? Do you think its the fan module and where is it located, can i test it?
  8. alan
    10-07-2015 12:48 AM - permalink
    alan
    hi mike i have following your posts from the guy from Germany i have a ssr in uk 30000 miles any advise as to what might go wrong ? if so can i buy your ignition kits etc thanks alan i find your knowledge amaxing
  9. Rad05
    10-14-2012 10:31 AM - permalink
    Rad05
    Hi Mike , I have been trying to check my fan operation, if the engine is started
    and the A.C. is turned on will the fan come on imediately ? My A.C pump just cycles very fast. The fan finaly came on at about 210-215. I replaced the coolant
    cap and the thermostat before i tested the A.C, I have been having overheating
    problems and got your message on how to check the fan operation.
  10. Watashi
    09-30-2012 07:32 AM - permalink
    Watashi
    Anything on the Front License Plate Mounts your expecting yet?

  About Me

  • About Mike in AZ
    Location
    Phoenix, Arizona
    Interests
    Fixing Stuff that the OEM missed
    Occupation
    Retired Turbine Engine Controls Engineer
    My SSR
    "BLOWN06" Pac Blue #21661 Born 8/29/05
  • Signature
    Trust and Generosity are contagious.

    One of the "Blues Brothers"

    www.simple-engineering.com

  Statistics

Total Posts
Visitor Messages
General Information
  • Join Date: 08-02-2005

  Friends

Showing Friends 1 to 10 of 100

  Mentions

04-04-2016
12:25 PM - Administrator mentioned Mike in AZ in post New site look and software upgrade Feedback Thread
...Regards, Mike Mike in AZ You still having ...

  Quotes

05-25-2016
09:32 PM - DOOPHUS quoted Mike in AZ in post The Word Association Game
headache HEARTACHE ! :sma...
09:25 PM - Mike in AZ quoted Krazy Ed in post The Word Association Game
... :black: :purple: Krazy Ed headache
06:08 PM - Mike in AZ quoted svetter84 in post Fan over heating.
I Appreciate it Mike, I will j...
07:23 AM - Mike in AZ quoted svetter84 in post It's a bad plug......
I have an 03 and I have also i...
05-24-2016
10:33 PM - Mike in AZ quoted Engineer in post SSR died at Maggie Valley Rally
I just got a new switch from ...
05:05 AM - Mike in AZ quoted Mitmidnite in post Need Help w/ Fuse ID
Thanks for responding. R is an...
05-22-2016
10:47 PM - Mike in AZ quoted birdmans in post WANTED: Bed Mat
...........B.M. Hey birdmans..... The official...
05:38 PM - Veloce quoted Mike in AZ in post Rear Lowering Springs to come from Simple Engineering
Any new time on availability? ...
05:16 PM - SSR2006 quoted Mike in AZ in post WANTED: Bed Mat
Thanks Mike but I am hopeful I ...
04:20 PM - Mike in AZ quoted SSR2006 in post WANTED: Bed Mat
Thanks but I am looking for ...
03:16 PM - Mike in AZ quoted Hdpartsman in post Rear Lowering Springs to come from Simple Engineering
Any new time on availability? ...
09:30 AM - ttarob quoted Mike in AZ in post The Word Association Game
Buick Chevrolet
05:56 AM - Mike in AZ quoted Krazy Ed in post The Word Association Game
... :black: :purple: Krazy Ed Buick
05-21-2016
02:34 PM - Mike in AZ quoted Focks in post Who Made these?
If the one I have doesn't ...
09:09 AM - Mitmidnite quoted Mike in AZ in post Who Made these?
I can answer this pretty easily...
01:08 AM - SSRNoir quoted Mike in AZ in post Worth every penny...
I can answer this pretty easily...
05-20-2016
11:36 PM - xoxoxoBruce quoted Mike in AZ in post Who Made these?
I can answer this pretty easily...
10:32 PM - Flassh quoted Mike in AZ in post Who Made these?
I can answer this pretty easily...
05-16-2016
12:40 PM - Mike in AZ quoted Mo and Andrea in post Being Cautious......
The factory installed anti-theft s...
05-15-2016
02:34 PM - Mike in AZ quoted river_rat in post My two cents
..... ................. ...
 
For the best viewing experience please update your browser to Google Chrome