Clicking Noise from dash?!!!! - Chevy SSR Forum
 8Likes
  • 1 Post By TruckNRod
  • 2 Post By dave rasmussen
  • 2 Post By Dragon2U
  • 1 Post By Shadowman
  • 1 Post By Shadowman
  • 1 Post By Dicktator
 
LinkBack Thread Tools Display Modes
post #1 of 21 (permalink) Old 01-25-2019, 09:58 AM Thread Starter
SSR Pit Crew
Lifetime Supporting Member
 
Mcolardeau's Avatar
 
Join Date: Jul 2018
Location: Palm Bay, FL
Posts: 14


Garage
Clicking Noise from dash?!!!!

Just started this morning, a pretty loud clicking noise coming from what seems to be under the dash on passenger side ... Happens when truck is running. When itís happening as the blower for the a/c slows with every click and lights seem to be dimming at same time clicking sound happens. Any ideas? Please! I recorded a video of it with sound and can send it to anyone in case anyone might have better insight on whatís going on
Mcolardeau is offline  
Sponsored Links
Advertisement
 
post #2 of 21 (permalink) Old 01-25-2019, 10:59 AM
SSR Pit Crew
Supporting Member
 
TruckNRod's Avatar
 
Join Date: Jun 2013
Location: Newcastle, CA
Posts: 450


My SSR:
#118755, DOB 12/2/04, 2005, 6 spd, smokin asphalt, boards, bed carpet, gauges, purchased June, 2013
Garage
Likely the outside air blend door actuator has stripped a gear tooth. Lots of threads here discussing the issue. Here’s one to get you started: https://www.ssrfanatic.com/forum/f5/...acement-60548/

Mine broke last year and I was sble to replace it following Dragon’s instructions.
yellow bear likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Keep on Truck-N
TruckNRod is offline  
post #3 of 21 (permalink) Old 01-25-2019, 11:20 AM
SSR Pit Crew
Lifetime Supporting Member
 
dave rasmussen's Avatar
 
Join Date: Sep 2013
Location: Nebraska
Posts: 1,507


My SSR:
2005 6 spd. BLACK
Ouch

My condolences.

Dave
dave rasmussen is online now  
Sponsored Links
Advertisement
 
post #4 of 21 (permalink) Old 01-25-2019, 01:34 PM
Super Road Rocket Pilot
Lifetime Supporting Member
 
Dragon2U's Avatar
 
Join Date: Jul 2005
Location: Georgia
Posts: 5,641


My SSR:
Empty Garage - Previous 03 04 05 owner - on hunt for next one ;)
Quote:
Originally Posted by Mcolardeau View Post
Just started this morning, a pretty loud clicking noise coming from what seems to be under the dash on passenger side ... Happens when truck is running. When it’s happening as the blower for the a/c slows with every click and lights seem to be dimming at same time clicking sound happens. Any ideas? Please! I recorded a video of it with sound and can send it to anyone in case anyone might have better insight on what’s going on
Quote:
Originally Posted by TruckNRod View Post
Likely the outside air blend door actuator has stripped a gear tooth. Lots of threads here discussing the issue. Here’s one to get you started: https://www.ssrfanatic.com/forum/f5/...acement-60548/

Mine broke last year and I was sble to replace it following Dragon’s instructions.
While I would normally agree it would be a blend door issue, it should not cause any problems with lighting, power or any other equipment. Sounds like you might have a bad fan, causing a short and creating power fluctuations. I would NOT operate it until someone did more troubleshooting on it. Fan is easy to get to, right there under the passenger dash.

Unplug the fan and see if the problem goes away, if so I would search for a new or used fan to replace it with. If not, tell us what disconnecting the fan motor did if anything to change the issue.
Autoprof and RedHotSSR like this.

Add your location on Fanatic PINMAP and locate others
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dragon2U is online now  
post #5 of 21 (permalink) Old 01-25-2019, 03:30 PM
SSR Pit Crew
Lifetime Supporting Member
 
nj6969's Avatar
 
Join Date: Jun 2014
Location: Forney tx
Posts: 2,949


My SSR:
2006 #107 of 199 Smokin Asphalt FPR's bought 6-18-2014; Kathy's '04 Ultra Violet Bought 2-1-'17
Garage
Sounds like the Blower motor.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Nick '06 Smokin Asphalt FPR & Kathy '04 Ultra Violet
nj6969 is online now  
post #6 of 21 (permalink) Old 01-25-2019, 04:23 PM
SSR Pit Crew
Supporting Member
 
Texasbaehr's Avatar
 
Join Date: Jun 2016
Location: Montgomery, TX
Posts: 1,337


My SSR:
2004 Slingshot Yellow
Garage
Leaves and debris fall into the blower intake through the cowl vent under the hood and fill up the squirrel cage causing it to make noise and get unbalanced. It tears up the bearings and then fails. Its easy to pull the blower from under the dash. See Dictators DIY Library for removal instructions, replacements are still available.

Insanity: Doing the same thing over and over and expecting a different result.
Texasbaehr is online now  
post #7 of 21 (permalink) Old 01-29-2019, 08:46 AM
SSR Pit Crew
Lifetime Supporting Member
 
Shadowman's Avatar
 
Join Date: Aug 2008
Location: Port St Lucie, FL
Posts: 1,570


My SSR:
No SSR, looking for next one;-
Easy is a relative term. Easy if your skinny and can stand on your head, not so easy if your old and fat. 😂 I’m in the latter category and did change one though, so I guess anyone can do it.
RedlineRyder likes this.

If you search the world for happiness, you may find it in the end, for the world is round and will lead you back to your door. ~Robert Brault
Shadowman is offline  
post #8 of 21 (permalink) Old 01-29-2019, 09:08 AM
SSR Pit Crew
Lifetime Supporting Member
 
jackatg450's Avatar
 
Join Date: Dec 2007
Location: Picayune, MS
Posts: 1,725


My SSR:
2005 Two Tone Jet Black&Chrome Auto
Instructions.

Click on this link for instructions with pictures on Dick's "How To Cloud". https://onedrive.live.com/?cid=3EF39...%21853&o=OneUp If the pictures don't open click on "OPEN" on left side.

Jack

It is not easy being a Hyper Old Person.

Jack Pruitt
jackatg450 is offline  
post #9 of 21 (permalink) Old 01-29-2019, 09:49 AM
SSR Pit Crew
Lifetime Supporting Member
 
nj6969's Avatar
 
Join Date: Jun 2014
Location: Forney tx
Posts: 2,949


My SSR:
2006 #107 of 199 Smokin Asphalt FPR's bought 6-18-2014; Kathy's '04 Ultra Violet Bought 2-1-'17
Garage
Quote:
Originally Posted by Shadowman View Post
Easy is a relative term. Easy if your skinny and can stand on your head, not so easy if your old and fat. 😂 Iím in the latter category and did change one though, so I guess anyone can do it.
So, was the Blower motor bad? or was it leaves/trash in it?

Nick


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Nick '06 Smokin Asphalt FPR & Kathy '04 Ultra Violet
nj6969 is online now  
post #10 of 21 (permalink) Old 01-29-2019, 05:04 PM
Super Road Rocket Pilot
Lifetime Supporting Member
 
Dragon2U's Avatar
 
Join Date: Jul 2005
Location: Georgia
Posts: 5,641


My SSR:
Empty Garage - Previous 03 04 05 owner - on hunt for next one ;)
Quote:
Originally Posted by nj6969 View Post
So, was the Blower motor bad? or was it leaves/trash in it?

Nick
Last log in was the 26th..... hope we get an update, I hate it when you don't get feedback after offering advice........

Add your location on Fanatic PINMAP and locate others
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dragon2U is online now  
post #11 of 21 (permalink) Old 01-29-2019, 05:20 PM
SSR Pit Crew
Lifetime Supporting Member
 
nj6969's Avatar
 
Join Date: Jun 2014
Location: Forney tx
Posts: 2,949


My SSR:
2006 #107 of 199 Smokin Asphalt FPR's bought 6-18-2014; Kathy's '04 Ultra Violet Bought 2-1-'17
Garage
Quote:
Originally Posted by nj6969 View Post
So, was the Blower motor bad? or was it leaves/trash in it?

Nick
Quote:
Originally Posted by Dragon2U View Post
Last log in was the 26th..... hope we get an update, I hate it when you don't get feedback after offering advice........
Oppps----my mistake. Shadowman was not the original poster!! my senior moment.

Nick


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Nick '06 Smokin Asphalt FPR & Kathy '04 Ultra Violet
nj6969 is online now  
post #12 of 21 (permalink) Old 01-30-2019, 07:47 AM
SSR Pit Crew
Lifetime Supporting Member
 
Shadowman's Avatar
 
Join Date: Aug 2008
Location: Port St Lucie, FL
Posts: 1,570


My SSR:
No SSR, looking for next one;-
Not sure, but it had a lot of debris in it. Since I had a new one in my hand I just decided to replace it rather than put the old one back and risk having to do a do over.
nj6969 likes this.

If you search the world for happiness, you may find it in the end, for the world is round and will lead you back to your door. ~Robert Brault
Shadowman is offline  
post #13 of 21 (permalink) Old 01-30-2019, 07:58 AM
SSR Pit Crew
Lifetime Supporting Member
 
Dicktator's Avatar
 
Join Date: Nov 2006
Location: Clearwater, Fl
Posts: 11,231


My SSR:
04 Silver/Race Stripes 4:10 gears tuned at 130mph lowered 2"
More likely debris, leaves and such, common problem. Trailblazer blower motor.

Go to my SSR How to Library:

https://onedrive.live.com/?id=3EF39D...F39D9F5ADCE5E5

Look up: BLOWER MOTOR

See all the leaves I found in mine?

Dicktator
Attached Thumbnails
Click image for larger version

Name:	10-0518 15.jpg
Views:	27
Size:	135.5 KB
ID:	540847   Click image for larger version

Name:	10-0518 14.jpg
Views:	24
Size:	114.9 KB
ID:	540849   Click image for larger version

Name:	14-0924 05.jpg
Views:	28
Size:	185.2 KB
ID:	540851   Click image for larger version

Name:	14-0924 17.jpg
Views:	30
Size:	85.5 KB
ID:	540853  
RedlineRyder likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dicktator is offline  
post #14 of 21 (permalink) Old 01-30-2019, 08:36 AM
SSR Pit Crew
Lifetime Supporting Member
 
Shadowman's Avatar
 
Join Date: Aug 2008
Location: Port St Lucie, FL
Posts: 1,570


My SSR:
No SSR, looking for next one;-
Hey, a new motor is under 50 bucks, and they are a pain to change out, especially if you do it twice. Just sayin..........

If you search the world for happiness, you may find it in the end, for the world is round and will lead you back to your door. ~Robert Brault
Shadowman is offline  
post #15 of 21 (permalink) Old 01-30-2019, 09:02 AM
Daily Driver
Lifetime Supporting Member
 
xoxoxoBruce's Avatar
 
Join Date: Nov 2006
Location: DelCo, PA
Posts: 8,643


My SSR:
'06- Silver/Copper- 121421
It was the smart thing to do. Hook the old motor up to power, through a resister pack if possible, and if it's quiet keep it for a spare.

Often wrong...... but never in doubt.
xoxoxoBruce is offline  
post #16 of 21 (permalink) Old 01-30-2019, 09:29 AM
SSR Pit Crew
Lifetime Supporting Member
 
Mr. Bill's Avatar
 
Join Date: Oct 2013
Location: Raleigh, NC
Posts: 825


My SSR:
2006 SSR 3SS 6-Sp Redline Red FPR/Phil Cochran Tune/P&P TB & IT/K&N/Dragon2U Bling/Mike's Stuff.
Garage
Send a message via Skype™ to Mr. Bill
Quote:
Originally Posted by Texasbaehr View Post
Leaves and debris fall into the blower intake through the cowl vent under the hood and fill up the squirrel cage causing it to make noise and get unbalanced. It tears up the bearings and then fails. Its easy to pull the blower from under the dash. See Dictators DIY Library for removal instructions, replacements are still available.
Dragon's cowl vent covers will fix the debris problem and they really add to the underhood bling. Great work again Mike! Bill


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

LCC Patch Order Info:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mr. Bill is offline  
post #17 of 21 (permalink) Old 01-31-2019, 09:37 AM
SSR Pit Crew
Lifetime Supporting Member
 
Dicktator's Avatar
 
Join Date: Nov 2006
Location: Clearwater, Fl
Posts: 11,231


My SSR:
04 Silver/Race Stripes 4:10 gears tuned at 130mph lowered 2"
Yes, you need to stop leaves/debris from coming into motor.

On my How to Library.

I used vinyl screen to seal off opening in cowl.

Dicktator
Attached Thumbnails
Click image for larger version

Name:	10-0519 02.jpg
Views:	44
Size:	125.2 KB
ID:	540901   Click image for larger version

Name:	10-0519 04.jpg
Views:	42
Size:	142.5 KB
ID:	540903   Click image for larger version

Name:	10-0519 03.jpg
Views:	44
Size:	126.1 KB
ID:	540905  


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dicktator is offline  
post #18 of 21 (permalink) Old 02-04-2019, 10:20 PM Thread Starter
SSR Pit Crew
Lifetime Supporting Member
 
Mcolardeau's Avatar
 
Join Date: Jul 2018
Location: Palm Bay, FL
Posts: 14


Garage
Sorry for the delay fellas, blower motor is good and clean. I have a feeling it may be one of the actuators. Haven’t had a chance yet to take it apart and look at it. I do have a video I recorded if the sound of someone would me to text or email it to them. Thank you again for all the advice and inquiries! I can’t tell you how valuable everyone on this forum has been thus far!!
Mcolardeau is offline  
post #19 of 21 (permalink) Old 02-04-2019, 10:32 PM
Daily Driver
Lifetime Supporting Member
 
xoxoxoBruce's Avatar
 
Join Date: Nov 2006
Location: DelCo, PA
Posts: 8,643


My SSR:
'06- Silver/Copper- 121421
Check out this thread.

Often wrong...... but never in doubt.
xoxoxoBruce is offline  
post #20 of 21 (permalink) Old 02-04-2019, 10:39 PM Thread Starter
SSR Pit Crew
Lifetime Supporting Member
 
Mcolardeau's Avatar
 
Join Date: Jul 2018
Location: Palm Bay, FL
Posts: 14


Garage
A side note that I just figured out since the noise has been happening ..... if I press the recirculate button, it blinks three times and then turns off. It doesn’t stay on. Idk if that helps anyone out. Thanks again
Mcolardeau is offline  
post #21 of 21 (permalink) Old 02-05-2019, 09:59 AM
SSR Pit Crew
Lifetime Supporting Member
 
Dicktator's Avatar
 
Join Date: Nov 2006
Location: Clearwater, Fl
Posts: 11,231


My SSR:
04 Silver/Race Stripes 4:10 gears tuned at 130mph lowered 2"
Quote:
Originally Posted by Mcolardeau View Post
A side note that I just figured out since the noise has been happening ..... if I press the recirculate button, it blinks three times and then turns off. It doesn’t stay on. Idk if that helps anyone out. Thanks again
Here is some reading:

SSR How to Library:

https://onedrive.live.com/?id=3EF39D...F39D9F5ADCE5E5

Actuator Blend Door took 5hrs to change and we never got it to work.

Dicktator

If you remove all this, you can get to Blend Door Actuator. Best fix? Unplug actuator.
Attached Thumbnails
Click image for larger version

Name:	15-0113 01.jpg
Views:	29
Size:	105.2 KB
ID:	541157   Click image for larger version

Name:	15-0113 34.jpg
Views:	33
Size:	123.9 KB
ID:	541159   Click image for larger version

Name:	15-0113 39.jpg
Views:	37
Size:	115.8 KB
ID:	541161   Click image for larger version

Name:	15-0113 50.jpg
Views:	32
Size:	121.3 KB
ID:	541163   Click image for larger version

Name:	15-0113 69.jpg
Views:	38
Size:	100.4 KB
ID:	541165  



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dicktator is offline  
Sponsored Links
Advertisement
 
Reply

  Chevy SSR Forum > SSR Discussion > SSR Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy SSR Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome