Power outlets under the dash - Chevy SSR Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-26-2019, 06:47 AM Thread Starter
Member
 
Join Date: Jun 2018
Location: Terre Haute Indiana
Posts: 18


My SSR:
Red 2004
Power outlets under the dash

My 2 power outlets under the dash do not work but the ash tray does how can I get these to work?
oldfarmboy is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-26-2019, 07:04 AM
Supporting SSR Hobbyist
Lifetime Supporting Member
 
Mike in AZ's Avatar
 
Join Date: Aug 2005
Location: Phoenix, Arizona
Posts: 9,090


My SSR:
"BLOWN06" Pac Blue #21661 Born 8/29/05
Quote:
Originally Posted by oldfarmboy View Post
My 2 power outlets under the dash do not work but the ash tray does how can I get these to work?
Check the Aux Power fuse in the rear fuse block. On the 2006, it is the 20 amp fuse in #46.

Mike

One of the "Blues Brothers"

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mike in AZ is offline  
post #3 of 4 (permalink) Old 05-26-2019, 09:34 AM
SSR Pit Crew
Lifetime Supporting Member
 
Dicktator's Avatar
 
Join Date: Nov 2006
Location: Clearwater, Fl
Posts: 11,240


My SSR:
04 Silver/Race Stripes 4:10 gears tuned at 130mph lowered 2"
Quote:
Originally Posted by oldfarmboy View Post
My 2 power outlets under the dash do not work but the ash tray does how can I get these to work?
Ash Tray and Tech2 Diagnostic Plug are on separate circuit.

Dicktator


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dicktator is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 05-26-2019, 09:45 AM
SoCal Nut/SuperModerator
Lifetime Supporting Member
 
BlueStreak's Avatar
 
Join Date: Apr 2007
Location: Pasadena, CA
Posts: 25,864


My SSR:
#23198 06Blue 3SS #375/532-BOD 12/21/05, got it 9/5/06 & #21474 #29/532-BOD 8/24/05, got it 12/1/15
Garage
Quote:
Originally Posted by Mike in AZ View Post
Check the Aux Power fuse in the rear fuse block. On the 2006, it is the 20 amp fuse in #46.

Mike
From reading Autoprof's post on rewiring those power outlets on his 2004 SSR it appears that Fuse #46 is also the source in the 2004s.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Therapy is Expensive Wind is Cheap
One of the Blues Brothers
BlueStreak is online now  
Sponsored Links
Advertisement
 
Reply

  Chevy SSR Forum > SSR Discussion > SSR Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy SSR Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome