Chevy SSR Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 20 of 28 Posts

·
Black "R"
Joined
·
50 Posts
Discussion Starter · #1 ·
Hi Guys,

New to Fanatics and love all the input. Seems all things SSR including "The Famous Fuse Box Wire Problem" can and will be solved ! (Thanks, Dicktator)
Just bought my R. Have been wanting one for too long. And just joined the Fanatics. Thank God!
Three days ago was out for a drive , sunny California, pulled in for some gas , after 1.5 hours of driving , and went to start. "NO START"
Pushed her out of the gas bay , called a tow truck and was waiting. Went on the forum and thought I found the problem? Removed the fuse box cover , let er cool , and just as the tow pulled in, she started!!!

This morning ,pulled the fuse box and went to Chevy (just to see if they new ANYTHING , about the fix) NO and the fuse box $$$$800.0 . With a faulty wire.
Got back home tonite , went back to Fanatics , and again , thanks Dicktator, found some great pics of the "infamous wire" which needs replacement.

I have 2 questions , for Dicktator , 1) How do I seperate the fuse box? (without destroying it).
2) The infamous wire is what gauge and where might I find that type of wire? (is it special)

Could it be as easy as Home Depot ? and the correct gauge ? or maybe I have it in my garage.
Please help if you can and would love to hear from you, Dicktator !!
Thanks for getting me this far. I love this site !! And my R
Chris
 

·
Premium Member
Joined
·
1,409 Posts
Hi Guys,

New to Fanatics and love all the input. Seems all things SSR including "The Famous Fuse Box Wire Problem" can and will be solved ! (Thanks, Dicktator)
Just bought my R. Have been wanting one for too long. And just joined the Fanatics. Thank God!
Three days ago was out for a drive , sunny California, pulled in for some gas , after 1.5 hours of driving , and went to start. "NO START"
Pushed her out of the gas bay , called a tow truck and was waiting. Went on the forum and thought I found the problem? Removed the fuse box cover , let er cool , and just as the tow pulled in, she started!!!

This morning ,pulled the fuse box and went to Chevy (just to see if they new ANYTHING , about the fix) NO and the fuse box $$$$800.0 . With a faulty wire.
Got back home tonite , went back to Fanatics , and again , thanks Dicktator, found some great pics of the "infamous wire" which needs replacement.

I have 2 questions , for Dicktator , 1) How do I seperate the fuse box? (without destroying it).
2) The infamous wire is what gauge and where might I find that type of wire? (is it special)

Could it be as easy as Home Depot ? and the correct gauge ? or maybe I have it in my garage.
Please help if you can and would love to hear from you, Dicktator !!
Thanks for getting me this far. I love this site !! And my R
Chris
first of all welcome Chris..here's the place to resolve many problems:

click on FORUMS
click on SSR DISCUSSIONS
click on TECHNICAL DISCUSSIONS
click on (DIY) DO IT YOURSELF

i hope this helps!!!
 

·
Premium Member
2003 Chevy SSR, Customized
Joined
·
604 Posts
I can perform a permanent fix without taking the fuse box apart.
Send me the fuse box and I will fix it and reship it the same day.
PM me for details.
 

·
Super Road Rocket Pilot
Joined
·
6,503 Posts
Hi Guys,

New to Fanatics and love all the input ...... I have 2 questions ........

1) How do I seperate the fuse box? (without destroying it).
2) The infamous wire is what gauge and where might I find that type of wire? (is it special)

A home repair is not extremely difficult, just be careful. replacing the wire is the best solution so there is no chance of future arcing or other issues and it only takes a few minutes -

1. To take apart the fuse box, tap out the bolts from the back (threaded side), take a drill bit slightly larger than the metal flange from where you pushed the bold out from and remove some of the metal. A little at a time. Then take a punch and tap them out by hitting the countoured area about halfway down into the sleeve. If you take just enough metal away to get them out they will snap back in. No worries if you take too much off, they will still hold the connectors when reassembled.

2, The copper wire is available many places, I use .032 20 gauge from Hobby Lobby for $2. You could also solder the connection instead of replacing it. Many people with other vehicles have had good success just laying a good bead of solder across the cracked area bridge. Corvettes and Trailblazers have the same issue and have performed the same solutions for years.

Good Luck

Link Online Procedure - Fuse Box disassemble
 

·
SSR Pit Crew
Joined
·
13,287 Posts
Hi Guys,

New to Fanatics and love all the input. Seems all things SSR including "The Famous Fuse Box Wire Problem" can and will be solved ! (Thanks, Dicktator)
Just bought my R. Have been wanting one for too long. And just joined the Fanatics. Thank God!
Three days ago was out for a drive , sunny California, pulled in for some gas , after 1.5 hours of driving , and went to start. "NO START"
Pushed her out of the gas bay , called a tow truck and was waiting. Went on the forum and thought I found the problem? Removed the fuse box cover , let er cool , and just as the tow pulled in, she started!!!

This morning ,pulled the fuse box and went to Chevy (just to see if they new ANYTHING , about the fix) NO and the fuse box $$$$800.0 . With a faulty wire.
Got back home tonite , went back to Fanatics , and again , thanks Dicktator, found some great pics of the "infamous wire" which needs replacement.

I have 2 questions , for Dicktator , 1) How do I seperate the fuse box? (without destroying it).
2) The infamous wire is what gauge and where might I find that type of wire? (is it special)

Could it be as easy as Home Depot ? and the correct gauge ? or maybe I have it in my garage.
Please help if you can and would love to hear from you, Dicktator !!
Thanks for getting me this far. I love this site !! And my R
Chris
It is easier to do ED's Fix aka ED in Fl. but if you want to do wire, all instructions, step by step are on How to Library.

Dicktator
 

·
Black "R"
Joined
·
50 Posts
Discussion Starter · #7 ·
Hi All,
My 05 R fuse box repair has now been completed.???
Upon opening the hood , I found something very unexpected. The box cover looked different, No screws , for water to leak in? The cover showed signs of an angry mechanic, broken plastic clips and latches.(All relays and fuses looked identical to pics posted)
I removed the box,(found a very hot , melted block connector,see pics). I split the box open, Thanks guys ! Upon opening the fuse box I found something very unexpected. The inside of my box looked nothing like all posted pics in Fanatics!!
And continued on my path of wire repair. I identified bad looking wires, overheated,corroded and too many bends. I located 3 suspect wires. and proceeded to replace them. I am trying to post pics(not too good computer tech) of my procedure,wires replaced and bad wires for all to see, in the hopes that anyone may help with my odd box.
After my reinstallation of the box, in the R, I replaced relays 42 and 43. The R fired immediately. I felt great!!
Proceeded to go for a test drive, and heat-up of the box. Coming up to an hour of driving, my check engine lite came on and shut down at 30 mph??? My heart sank. Pushed her to the side and let traffic pass. Popped the hood, opened the box, (42 and 43 were pretty hot), let er cool and in about 35 min she restarted. Still engine lite on. Drove her home, and went out dancing with my lady.
I obviously did not get the right wire! Yet one of the 3 replaced was so badly corroded, I was positive it was the problem, ready to break!?
So I guess its back to the box repair! I did not check each wire with a test light or OHM meter. Thought the box being different and the corroded and hot wires, it was kinda senseless. I now think I was wrong.
I am looking for any and all help.
I have included my VIN for searches. What I found with the VIN was not pleasing. My R has a 4 page rap sheet of repairs from mile one !! to mile 40,000. Either she was owned by a person of ultimate pickiness or is a LEMON.
The repairs show all types ,inclusive of, PCM and ECM,ignition switch, replace, yet no fuse box. And all indications point this shutdown has been plaguing her since birth. I would love to see her rid of this disease ! Again , any help is greatly appreciated. And much thanks to Dicktator,ED in FL ,Cricketman and Al.
If it is thought best, I am happy to send the box to Dicktator , ED , Al, for a diagnosis and replacement, yet not sure as it is an oddball box? Nonetheless pulling it out today.
Looking for HELP
Thanks,
Chris.
 

·
Premium Member
Joined
·
3,187 Posts
good photos

thanks for sharing

I hope you can find a permanent solution
 

·
Daily Driver
Joined
·
8,997 Posts
... I removed the box,(found a very hot , melted block connector,see pics). I split the box open, Thanks guys ! Upon opening the fuse box I found something very unexpected. The inside of my box looked nothing like all posted pics in Fanatics!!
~snip~
So I guess its back to the box repair! I did not check each wire with a test light or OHM meter. Thought the box being different and the corroded and hot wires, it was kinda senseless. I now think I was wrong.
~snip~
If it is thought best, I am happy to send the box to Dicktator , ED , Al, for a diagnosis and replacement, yet not sure as it is an oddball box? Nonetheless pulling it out today.
Looking for HELP
Thanks,
Chris.
At first when you said "different" I thought you meant because it was so corroded(flood car?), but then you seemed to be saying the box was physically different, so I went looking for pictures. Now I'm even more confused.
 

Attachments

·
Premium Member
Joined
·
609 Posts
What symptoms should occur before we send it to "ED in FL"
 

·
Super Road Rocket Pilot
Joined
·
6,503 Posts
Hi All,
My 05 R fuse box repair has now been completed.???
..... I removed the box,(found a very hot , melted block connector,see pics)......
Chris, that block connector needs attention asap. A new connector should be installed, possible wire repair / replacement and further troubleshooting on that particular line. Looks like the connector might not be getting good contact or was very corroded and arcing.


...........I split the box open, Thanks guys ! Upon opening the fuse box I found something very unexpected. The inside of my box looked nothing like all posted pics in Fanatics!!
Thanks,
Chris.
The wire you seek is on the opposite side of the trace layout you took pictures of. If you look on the backside of the item you took pictures of you will see the trace layouts that look like picture 2 of what xoxoxoBruce posted, thanks Bruce. The bad wire that is a common issue is in that picture, the wire that looks like a backwards "C" that is on the most right had side of the layout. The wire goes from the bottom to the top of the layout, the small section that turns inward along the long upward layout is the problem area.

You will need to take it apart again, completely remove the middle wire trace section, just slides apart, and look on the other side to replace the bad "C" wire.


Veloce - you know the fuse box wire has issues when the truck has an intermittent running issue. Usually will run okay when cool but might shut off and/or not start when warm.
 

·
SSR Pit Crew
Joined
·
13,287 Posts
I agree with Mike aka Dragon2U, need to replace connector and fix or find what caused short.

I have 05/06 Fuse Box in stock with Ed's repair.

BUT you need to address connector.

Dicktator
 

·
Black "R"
Joined
·
50 Posts
Discussion Starter · #19 ·
05 R fuse box bad wire

Hi to All,

First I need to make a correction. My Black "R"is 05 not 06.

I simply want to thank, EDinFL,Dictator,Dragon2U,Cricketman,xoxoxoBruce and Mike SimpleEngr
in Re to to all the help received in the past 4 weeks on my new 2 me
05
Black"R".

Without you guys , my life would have been a living hell, with my new purchase !
The care and simplicity with which the troubles were handled is remarkable. If all things in life were so simple , living would be that much easier.

My Black "R"is now constantly running , not shutting down constantly.
She is also running cool , with a new radiator fan ! And I am confident that any future issue is easily solved with the "Help Crew" of Fanatics !

Thanks again guys, And hope to one day be able to buy you all a beer, and look upon our "R" 's in the view.

Sincerely,
Chris,
Black"R"
 

·
SSR Pit Crew
Joined
·
13,287 Posts
Glad you got it resolved!

Another Family Member helped!

Feels good!

I will take a Capt' Morgan when we meet.

Beer is fattening.

Dicktator
 
1 - 20 of 28 Posts
Top