Chevy SSR Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi,
My Dad has a 2005 R he lives near Buffalo NY area. The truck was in storage for the winter with battery tender . New battery was put in October 2016.

When he went to start it, and ran about 20 seconds and then quit. He then tried to start it again and nothing. He turned the ignition off took the key out got out closed the door. Then got back in and it started again for 20 seconds. Could this be the ignition switch or something else?
Thank you for any information.
 

·
Premium Member
Joined
·
9,630 Posts
Probably the fuse box problem on a 05..do a search.. common problem.. easy temporary fix. Someone else will probably post with better details
 

·
Daily Driver
Joined
·
8,941 Posts
Doubt it's the fuse box, the engine would have to be fully up to temperature for that.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4 (Edited)
I did a search and read on the fuse box problem, but its a cold start up and not hot from driving.

Edit: I have more info from my dad. He said before it shuts off the check engine light comes on and the reduce engine power light and then it stops.
 

·
Super Road Rocket Pilot
Joined
·
6,272 Posts
Definitely not the common fuse problem but I am thinking a possible fuel pump issue? No codes? Try connecting a fuel pressure gauge to the fuel rail and watching it to see if the pressure drops off before the engine shuts down. 20 seconds every time? Hmmmmm, could be a fried ECM......
 

·
Premium Member
2004 Slingshot Yellow
Joined
·
1,919 Posts
If the check Engine light was on then their is a code. He needs to rent a code reader from a local Auto parts Store or borrow one from a friend and read the code so you can post it on here. That may narrow down the problem significantly.
Greg
 

·
ONE OWNER !!!!
2004 Smokin' Asphalt #11150
Joined
·
44,531 Posts
If the check Engine light was on then their is a code. He needs to rent a code reader from a local Auto parts Store or borrow one from a friend and read the code so you can post it on here. That may narrow down the problem significantly.
Greg
:agree I agree !!!!!!!
 

·
Premium Member
Joined
·
855 Posts
Could it be the DREADED ignition switch?

Mine went all wonky one time, couldn't start it and when I finally got it going it ran but wouldn't go very fast and the check engine light was on and the reduce engine power light was on.

The dealer spent $500 diagnosing it and it was just the ignition switch!
 
1 - 9 of 9 Posts
Top