Chevy SSR Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 ·
Hi listers,

Took my truck in for service and one item was a slight fan noise with the A/c on at low setting. when you acclerate it gets worse and then dissappears. Not real loud but still there at return to idel only at the low fan setting.

I was told they had a service bulliten on the problem and it was the compressor not the fan and their is no fix. Guess I will just have to add it to the list below the sun visors that don't stay put.

Anyone else have this problem?

Thanks,

David
 

·
Registered
Joined
·
10,950 Posts
Had mine replaced......there is sort of a noise still. Not as loud as before, but I don't think that there is a fix yet.
 

·
RetroCarGuy530
Joined
·
1,699 Posts
My 03 SSR had a nasty fan related noise on setting "2".

My 05 SSR does not have the fan related noise on setting "2" but it does (and the 03 did as well) have the slight tick/knock noise when on "1" or "2" which increases with the engine RPMs. Not as annoyinig the the fan "2" noise, but I can still hear this one.... I'll see how badly it bothers me after a couple of months.
 

·
Registered
Joined
·
4,222 Posts
Then and Now . . . . . . .

In the old days . . . and I mean the real old days, a slight ticking sound that increased with your speed meant you had something wrapped around your drive shaft or tangled in the universal(baling wire, empty paper sack, a half-dried out tumbleweed, etc.)

My how times have changed ! ! :lol :lol

Gary (WearyEagle)
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top