Chevy SSR Forum banner

1 - 19 of 19 Posts
V

·
Guest
Joined
·
0 Posts
Discussion Starter #1
On your 05 SSR's does your a/c compressors turn on and off every 30 seconds or so when the AC is on and the the recirculating mode button is on. The service guy is telling me this is normal. It's never been normal on any of my other cars.
 

·
Registered
Joined
·
93 Posts
A/c

Mine does not recycle like that, of the two 05's that I know of, neither one puts out a lot of Cold A/C compared to other cars and trucks I own. Mofo
 

·
Registered
Joined
·
95 Posts
Mofo said:
Mine does not recycle like that, of the two 05's that I know of, neither one puts out a lot of Cold A/C compared to other cars and trucks I own. Mofo
My 05 air doesn't seem to working correctly. The air temp warms up when backing of the gas. I've had 3 Vettes, multiple Burbs and Duallies, and the air never was like this.
Headed to the dealer next week.
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #5
Ac

:thumbs I know my AC will freeze you out. and not take too long about it. Now that the temp. has been 93-94, 80 % humidity. AC is on. put top down after dark or early in the day. :flag :seeya :leaving
 

·
Registered
Joined
·
35 Posts
04 a/c Q

My a/c started to sorta buzz on Saturday. I hear it as I accelerate, from about 10mph to 30 or so, after that I can't hear it, but I'm sure it is still doing something, but the frequency of the sound is too high for me to hear. The air doesn't get very cold either. I haven't had an occasion to run the a/c before this, that I can recall. I had been driving for about a half hour to 45 minutes, and suddenly I heard this sound as I pulled out from a parking spot. I drove 50 miles, and when I left from a stop sign, I head the noise and every time after that.

Let me guess...time to go see the service dept.
 

·
Registered
Joined
·
60 Posts
My '05 doesn't get cold at all, cycles a lot but air is cool not cold as in my Vette or wifes CTS or other vehicles I have owned.

George
 

·
Registered
Joined
·
10,950 Posts
If it ain't cold

If your A/C isn't blowing cold air.....it's broke.

I have found out that our climate control units are programmed and that they can "lose" their programming, but that means that it can work, but not as intended.

I also think that there is a problem with the A/C's that seem to cycle on and off....mine did that at some point in time, but no I no longer have THAT problem.
 

·
Registered
Joined
·
3,417 Posts
TerryH said:
My 05 air doesn't seem to working correctly. The air temp warms up when backing of the gas. .
We have noticed that ours blows cold when moving, but the air warms up at idle. We took it to the dealer and they said it was working within factory specs. We were wondering if increasing the idle speed would help this at all. Any ideas?? :confused
 

·
Registered
Joined
·
24 Posts
vettegirl said:
We have noticed that ours blows cold when moving, but the air warms up at idle. We took it to the dealer and they said it was working within factory specs. We were wondering if increasing the idle speed would help this at all. Any ideas?? :confused
I think part of the problem is that the condensor suffers the same fate as the radiator... not enough capacity. When you sit still, not much air is passing through that condensor, so the heat is not being transfered away, and the A/C blows warmer.

Also, some people still want cold air like the old days of R-12 freon (prior to 1995). It's not gonna happen, R-134a is never going to provide the same level of cooling as we had in the good 'ol days.

Here's what you need to do: Set your A/C system to recirculate mode. Let it blow and get nice and frosty. You'll find that you may actually need to adjust your temp setting at some point, because it will blow very very cold eventually.

Sitting in traffic in 95 degree heat will always be a problem. You can't adjust your idle, either. It is meant to be controlled by the ECM.
 

·
Registered
Joined
·
10,950 Posts
Recycle Air Button

Every once in a while when I've pushed my Recycle Air Button it blinked a couple of times then turned off. I couldn't for the life of me figure out why it did that....(I know I could have asked here, but it didn't seem THAT important)...

BUT I have the answer now! You can only turn the Recycle Air on when your air direction button is set to "vent out the dash" or "vent out the dash and under the dash". It will not work for "vent under dash", "vent under dast and defrost", "defrost", or "super defrost"

Now I wonder if anyone else cared...... :lol
 

·
Registered
Joined
·
254 Posts
Well yeah, I care

thanks for the tip otherwise I might have thought something was wrong. My '05 cools very well, blowing cold air seconds after turning on and then continuously . If it wasn't so hot here I would have to turn it down. Sitting in stop-and-go traffic will cause it to warm up, I think that's to be expected. :seeya
 

·
Enjoying life as it comes
Joined
·
5,201 Posts
just had mine serviced today

Took mine in for A/C service today for no cold air at all. The service tech and I worked on it side by side and follwed all the proceedures from GM. We checked the pcm, it's ok, we checked the module under the dashhbehind the glove box, it's ok, we checked the signal to the module in the roof stowage area, it's ok. we decided to unplug all a/c control wires on each module and check terrminals, they all seemed fine. Plugged everything back in and Voila, cold air again. Go figure, we hadn't replaced any parts just checked the connections.

We figured at this point we would let it sit while we attempted to get into the center console that the wife couldn't get into. After disassembling as much of the consloe as we could to get to the latch mechanism, we found that the lock system was broken inside, and wouldn't release the console tab. Went to the parts man and found that he had to order the entire center piece. I told him if that's what we have to do to get the one piece we need, then let's get it and we can change out just the lock when it comes in. Certainly don't want ot paint the upper section of the center console again.

Tried the air again before I left, and it is working better than it has before. If this occurs again we're going to order a control module (the on in the stowage area).
 

·
Tu-Tone club member
Joined
·
5,780 Posts
Good input, FUZZY

In this 110 heat index weather, mine is only cool also. The temp went up to 230 a couple of times when either idling or when restarted after a stop. My wife's Maxima will freeze you out, in the same conditions. What the ??????????

P/P

Peace :flag
 

·
Registered
Joined
·
1,502 Posts
FUZZY said:
Took mine in for A/C service today for no cold air at all. The service tech and I worked on it side by side and follwed all the proceedures from GM. We checked the pcm, it's ok, we checked the module under the dashhbehind the glove box, it's ok, we checked the signal to the module in the roof stowage area, it's ok. we decided to unplug all a/c control wires on each module and check terrminals, they all seemed fine. Plugged everything back in and Voila, cold air again. Go figure, we hadn't replaced any parts just checked the connections.

We figured at this point we would let it sit while we attempted to get into the center console that the wife couldn't get into. After disassembling as much of the consloe as we could to get to the latch mechanism, we found that the lock system was broken inside, and wouldn't release the console tab. Went to the parts man and found that he had to order the entire center piece. I told him if that's what we have to do to get the one piece we need, then let's get it and we can change out just the lock when it comes in. Certainly don't want ot paint the upper section of the center console again.

Tried the air again before I left, and it is working better than it has before. If this occurs again we're going to order a control module (the on in the stowage area).
BTW: Something like the credit card trick can be used to trip the console latch. Not with a credit card exactly but a carefull examination of how the latch works, should show the way.
 

·
Enjoying life as it comes
Joined
·
5,201 Posts
Tried Something On That Order

But it wouldn't release it. The console cover had too much tension on it by the time we got anything between it to attempt to release the cover. Taking it apart was our second option and it did accomplish what we needed. Finding the broken part.
 

·
Registered
Joined
·
740 Posts
Purple Penelope said:
In this 110 heat index weather, mine is only cool also. The temp went up to 230 a couple of times when either idling or when restarted after a stop. My wife's Maxima will freeze you out, in the same conditions. What the ??????????

P/P

Peace :flag
My air conditioner isn't keeping me cool in this hot weather either.

But I can't really blame GM. I mean, you'd have to have a hell of an air conditioner to keep things cool in a convertable.
 

·
Original SSR Centerfold
Joined
·
3,146 Posts
dougnc said:
My air conditioner isn't keeping me cool in this hot weather either.

But I can't really blame GM. I mean, you'd have to have a hell of an air conditioner to keep things cool in a convertable.
Now if everyone that had a convertable would turn their AC on high, would that cool things off for everyone????
 

·
Registered
Joined
·
72 Posts
My a/c does not cycle on and off as described. I would suspect a problem. It doesn't cool as well as my '00 Vette thus I run it in the recirc mode all the time. But its vent temperature is acceptable. I have observed that it will vary its operation when I have slowed down or am in idle but only for a few seconds. Hearing it change catches my attention. I also note that my engine temp is very stable with the a/c on and from the temperature gauge observations, you would conclude that it runs cooler with the a/c running.
 
1 - 19 of 19 Posts
Top