Chevy SSR Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Ride of the Month Challenge!
61 - 68 of 68 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #61 ·
Contact the RGang in Orlando. Not far from you.

Tom Sorensen aka Soren703 Phone 770-568-8092

Sounds like ignition switch, ever been changed??

Dicktator
No and and not sure why it should be...
You buy a truck, 17yrs OLD and now you want to sell.

You are right, buy a NEW truck, they NEVER have any problems.

Even a NEW wife while you are at it.

Dicktator
I've had this truck for quite some time...liked 5+ years with no problems to speak of. Make no assumptions about how long I've had this truck. These issues just started happening...
Thank you...
 

·
SSR Pit Crew
2004 Silver SSR with Strips. Owned 16yrs. Start 9K, now 159K miles
Joined
·
13,701 Posts
It's because it is "OLD"!

I go to Doctors more often than I did at 20 years old, so does yourTruck.

Dicktator
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #65 ·
I would recommend installing a spare EBCM that is known good. This will clear up several difficult questions that need to be answered. I have one that I can loan you. It would just be the cost of shipping it out to you and then back to me…….

You may also have a bad TCM, but I would wait on throwing money at that until you get the other random indications identified. Perhaps you have a bad 125 amp fuse on the engine fuse box. It feeds power to the cabin fuse box behind the passenger seat. That cabin fuse box supplies power to many of the things you listed as having ”erratic behavior”….. The failure mode on the 125 amp fuse is a minor fracture that becomes intermittent, just before failing altogether.

Hey @JimmySSBN …… welcome to the SSR family…… nice to see you came up for air.


Mike (VS-35 1969-73)
Mike...
Do you still have th EBCM spare I can borrow? I'd like to give your idea a try. If yes I will pay for shipping both ways.
My address is...
Jim Tarlton
350 N Federal Highway Unit 1212S
Boynton Beach Fl. 33435
Thanks for your help....
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #68 ·
Good catch Rich !!!

@JimmySSBN, Keep following Autoprof's advise. Meantime--Welcome from Forney Texas. Consider clicking on the Colored Letter/Picture, top far right corner, go down to "Account Settings", click, and fill in your information. Especially your LOCATION and the year of your SSR, like the rest of us. Then go the the left side and click on "Signature". Also put the year of your SSR in your "Signature", and anything else you want to show in your posts, and we can help you better if you have a problem. When you finish click the "SAVE" box.

Click here for the "How To Library" OneDrive

Also click on this link and go to Post #1 Help Us Help You---UPDATE

Then go to the "New Member Section" and introduce yourself. New Member Section

Nick & Kathy
It shows first great but it's not in first gear. I can shift into any gear and the trans indicator remains the same. One more of those erratic phantom indicators on the dash. The new modulator was installed and now code says sensors are not being read. EBCM will be now be tested and verified again by Module Master.
 
61 - 68 of 68 Posts
Top