Chevy SSR Forum banner
1 - 5 of 5 Posts

·
Super Road Rocket Pilot
Joined
·
6,979 Posts
The fan speeds 1-4 are controlled by the HVAC control module through the resistor network. The number 5 position is a direct path to the motor, it bypasses the resistor network.

If 5 is of a lower speed than 4 then you might have a ground or wiring issue. If everything seems fine then most likely something internal to the HVAC controller.
 

·
SSR Pit Crew
2004 Silver SSR with Strips. Owned 16yrs. Start 9K, now 159K miles
Joined
·
14,642 Posts
The fan speeds 1-4 are controlled by the HVAC control module through the resistor network. The number 5 position is a direct path to the motor, it bypasses the resistor network.

If 5 is of a lower speed than 4 then you might have a ground or wiring issue. If everything seems fine then most likely something internal to the HVAC controller.

What Mike said and there are part numbers on SSR How to Library, look up BLOWER MOTOR.

Link: https://onedrive.live.com/?id=3EF39D9F5ADCE5E5!853&cid=3EF39D9F5ADCE5E5

Dicktator
 

·
Premium Member
04 SSR
Joined
·
4,500 Posts
Mike is correct
The resistor assembly is bypassed in high speed -- however the HVAC module controls the ground of the blower motor for ALL speeds and uses the same grounds for all speeds.
SEE wiring diagram attached

The orange wire splits before going into the module to reduce the current though each terminal - it is possible that one of the terminals for the orange wires at the module is loose/corroded.
If you have access to a voltmeter you would want to test in the locations noted on the diagram
You should not unplug any wires - gently push voltmeter probe into backside off connector just enough to make contact with the terminal.

#1 should be about 12 volts engine off, 13-14 volts (engine running) all positions of blower switch
If less try another ground or problem is not enough power is getting to blower motor

#2 should vary based on blower speeds-voltage should decrease as blower speed increases, less is better(below.5volts in high)

#3 both readings at the back of module should be almost the same as reading #2 and should be low -(lower the better)

If you don't have voltmeter, then visually inspect connectors/terminals at HVAC module (orange and black ones in particular), check grounds and then best of luck finding a known good HVAC module as test unit.

I am also assuming the problem is both with the engine running and the engine off and nothing else changes when blower is switch to high (headlights dim, etc).

Let us know what you find out from testing so we can provide more assistance.
 

Attachments

1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top