Chevy SSR Forum banner

1 - 20 of 26 Posts

·
Premium Member
Joined
·
41 Posts
Discussion Starter #1
First time out with our R in quite some time and front brake started dragging, Back wheels turn fine. Front drivers locked and passenger will turn. Could ABS be the problem ?
19,500 miles and had brake fluid flushed @ 18,600. On jack stands wheels off any suggestions ? Thanks Steve & Bobbie
 

·
Premium Member
Joined
·
68 Posts
I would check to see if it has brake fluid. If you remove master cylinder cap and rubber is swollen someone added power steering or some other oil. If rubber looks fine it probably needs a caliber or hose on the side that isn't free . That is my guess.
 

·
Premium Member
Joined
·
41 Posts
Discussion Starter #3
I would check to see if it has brake fluid. If you remove master cylinder cap and rubber is swollen someone added power steering or some other oil. If rubber looks fine it probably needs a caliber or hose on the side that isn't free . That is my guess.
Thanks for reply, fluid looks find although I don't think dealer flushed it. Cracked bleeder and no fluid come out. Hub will move but rotor is locked tight.
 

·
Premium Member
Joined
·
2,584 Posts
Its been my experience that if it were a hose that was blocked or ABS valve issue, cracking a bleeder screw loose the brake would free up. This not being the case, my money is on a restricted/stuck caliper piston.
 

·
Premium Member
Joined
·
439 Posts
We had same problem. Calipers are piece of DOO-DOO, Replace the front before they really mess things up..
 

·
Premium Member
Joined
·
41 Posts
Discussion Starter #6
Thanks for reply, fluid looks find although I don't think dealer flushed it. Cracked bleeder and no fluid come out. Hub will move but rotor is locked tight.
Its been my experience that if it were a hose that was blocked or ABS valve issue, cracking a bleeder screw loose the brake would free up. This not being the case, my money is on a restricted/stuck caliper piston.
Thanks for that, I can see caliper on DR side out further on slider pins.
 

·
Registered
Joined
·
270 Posts
had the same problem and replaced all 4 calipers and while I was at it I replaced the rotors flushed the brake fluid. All is good to go ! Next is I need to replace front wheel bearings which is a simple thing to do
 

·
Premium Member
Joined
·
41 Posts
Discussion Starter #9
had the same problem and replaced all 4 calipers and while I was at it I replaced the rotors flushed the brake fluid. All is good to go ! Next is I need to replace front wheel bearings which is a simple thing to do
Thanks for reply, I'm going to flush brake system myself ,replace calipers, rotors and pads. Researching for Brand of pads and rotors with least amount of Dust
 

·
Premium Member
Joined
·
2,584 Posts
Word of advice, do not let system get low while replacing calipers. Bleeding ABS system on this can be tricky. It won't be an issue if you keep fluid in it though.
 

·
Registered
Joined
·
446 Posts
I have experienced the same on my RF twice.. Issue was slight corrosion of the pad retaining clip to the brake carrier.

Attempted to replace, but local auto part store "replacement kit" did not work. Found that h8odd as expected the calipers should be shared with Trail Blazer.

Anyway, cleaned up with 400 grit, little lube and good to go. I suspect infrequent use is my issue, so I just keep and eye on it and clean and lube as required. Good luck.
 

·
SSR Pit Crew
Joined
·
12,338 Posts
I tried other pads, they said they were better than OEM, NOT! What a mess.

Back to OEM, no problems after that.

But only have 148,000 on my R.

Dicktator

1. The pads that were "better" than OEM "gouged" my rotors. They did replace rotors and pads with OEM, FREE.
2. Back to OEM with new rotors
3. I also changed brake hose to braded stainless lines. ID is about twice that of OEM. Less chance for "junk" to stick in lines.
4. Braded Stainless Brake lines.
 

Attachments

·
Premium Member
Joined
·
41 Posts
Discussion Starter #14
Thanks for all input .Knew what to look for 1st time apart.

1-.pads were sticking
2-pins were working fine
3- 1 piston was (locked up stuck) 19,600 miles on my R
:cool: spc04
 

·
Premium Member
Joined
·
5 Posts
First time out with our R in quite some time and front brake started dragging, Back wheels turn fine. Front drivers locked and passenger will turn. Could ABS be the problem ?
19,500 miles and had brake fluid flushed @ 18,600. On jack stands wheels off any suggestions ? Thanks Steve & Bobbie
I have had the exact experience on a 2006 FPR SSR and calipers were locked. Replace your calipers
 

·
Premium Member
Joined
·
41 Posts
Discussion Starter #17
Thanks for reply's. Eye's healed from surgery back to seen of crime .Drivers side caliper was locked . Replaced calipers , rotors and flushed system. Drivers rotor still dragged some. Replaced hoses with NAPA parts everything worked find, but leak at hose to line fitting, the seat in new line is different After market stuff is junk..! .Does anyone have a part # of lines the will work ?
581584
This is original line , thanks for help and hope to show up soon. IMG_2185.jpg
IMG_2185.jpg
 
1 - 20 of 26 Posts
Top