Chevy SSR Forum banner

1 - 7 of 7 Posts

·
MY05SSR
Joined
·
589 Posts
Discussion Starter #1 (Edited)
On my 05, the cargo light has never worked since I got it. Bulb test good but no power at light. Book shows nothing as to what fuse. Tested all fuses on both boxes and they all seem fine. Can't find the switch that turns light on when hatch is open, anyone know anything about this light schematics. I've been ignoring it because of bigger issues but now the time has come
 

·
Spirited driver!
Joined
·
1,597 Posts
Hi John,

there is a well-known problem with the cargo light. It has a fuse that is too big for the circuit and when it shorts out it can cause a fire. The fuse is in the fuse block behind the passenger seat and it is fuse #40. You should replace it with a 1 or 2 amp fuse and replace the bed light with a LED bulb. If that doesn't work, at least pull that fuse and when you come to the GA rally next month you can get a replacement light and fuse kit from @Dicktator and have somebody there check your system to make sure it is not shorting out. In the meantime, you should read this thread: Cargo Bay Light Saftey
 

Attachments

·
My First Permagrin !
Joined
·
568 Posts
So if I remember from past posts the body control module sends the signal to the fuse circuit , the BCM is timed to go off after a few minutes. definitely change the fuse and bulb first and search fanatics forum for more information. Good luck .
 

·
Premium Member
2004 Slingshot Yellow
Joined
·
1,941 Posts
On my 05, the cargo light has never worked since I got it. Bulb test good but no power at light. Book shows nothing as to what fuse. Tested all fuses on both boxes and they all seem fine. Can't find the switch that turns light on when hatch is open, anyone know anything about this light schematics. I've been ignoring it because of bigger issues but now the time has come
The light is controlled by the rear compartment ajar switch to a small relay module under the hatch cover front left corner. You will see a connector and wire going into the LF corner of the hatch trim cover. If fuse 40 is OK then your module or the connector is most likely fried. Best to pull the fuse to prevent any further issues as this can cause a fire.
When I bought my 04 the light was no op. I found the module and connector were both burned up. I removed it and hard wired the light, replaced the fuse and bulb and added a switch behind the light.
Here's the wiring schematic the that circuit.
 

Attachments

·
Premium Member
Joined
·
2,984 Posts
Attached is the wiring diagram for the rear compartment light.

The rear compartment ajar switch is in the left rear latch -- I believe this is the same switch that will trigger the DIC to display "rear compartment ajar" or something similar

Note if you pull fuse 40 - it will also shut off your reading (map) lights and vanity mirror lights, if it matters.

I don't need the light so I just unplugged it.

EDIT
DAM Texas bear must have hit post about the same time - i switched to the lab manual to find the diagram
Oh well this is from Alldata - closer to the OEM then the one he posted from Mitchell (aka Snap-on Shop Key)
 

Attachments

·
MY05SSR
Joined
·
589 Posts
Discussion Starter #6
Cargo light

Attached is the wiring diagram for the rear compartment light.

The rear compartment ajar switch is in the left rear latch -- I believe this is the same switch that will trigger the DIC to display "rear compartment ajar" or something similar

Note if you pull fuse 40 - it will also shut off your reading (map) lights and vanity mirror lights, if it matters.

I don't need the light so I just unplugged it.

EDIT
DAM Texas bear must have hit post about the same time - i switched to the lab manual to find the diagram
Oh well this is from Alldata - closer to the OEM then the one he posted from Mitchell (aka Snap-on Shop Key)
I found fuse # 40 (good 15amp fuse) and took out cargo lamp bulb for now. I will get LED bulb tomorrow and I have 2 amp fuse but didn't install. I want to check rear compartment switch before I get parts because there is a break somewhere that I must find to even get LED light to work. I want to that all of your input on this from everyone. I guess I got rusty after 20 years of being away from it all. I'm glad I joined this group of very knowledgeable SSR Fanatics

Thanks again! John
 

·
MY05SSR
Joined
·
589 Posts
Discussion Starter #7 (Edited)
I found fuse # 40 (good 15amp fuse) and took out cargo lamp bulb for now. I will get LED bulb tomorrow and I have 2 amp fuse but didn't install. I want to check rear compartment switch before I get parts because there is a break somewhere that I must find to even get LED light to work. I want to that all of your input on this from everyone. I guess I got rusty after 20 years of being away from it all. I'm glad I joined this group of very knowledgeable SSR Fanatics
And 20 years ago I restored vettes, not SSR's
Thanks again! John

JohnPierce is online now Report Post
Edit Quote Multi-Quote Quick Reply
 
1 - 7 of 7 Posts
Top