Chevy SSR Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi....This will be my first post.
I have an '04. I have looked on-line, not extensively, for the temp the car should be running at. I haven't found any definitive facts. Several years ago I replaced the fan and shroud(aftermarket that created better flow). Just in the last couple months, I have replace the reservoir, Heater hoses (thanks Mike in AZ), water pump, thermostat and housing and the upper and lower radiator hoses, all work done but me. With all that done I am still running above 210. Once the gauge gets to the mark between the 210 and 260 mark the high gear of the fan kicks in and lowers the temp some. Part of me thinks I have just decided the temp should be running at 210 but the rest of thinks it is running hot and I can't determine why.

Thanks for reading and I appreciate any input.

Thanks
Tiffurs
 

·
Premium Member
Joined
·
2,202 Posts
Hi....This will be my first post.
I have an '04. I have looked on-line, not extensively, for the temp the car should be running at. I haven't found any definitive facts. Several years ago I replaced the fan and shroud(aftermarket that created better flow). Just in the last couple months, I have replace the reservoir, Heater hoses (thanks Mike in AZ), water pump, thermostat and housing and the upper and lower radiator hoses, all work done but me. With all that done I am still running above 210. Once the gauge gets to the mark between the 210 and 260 mark the high gear of the fan kicks in and lowers the temp some. Part of me thinks I have just decided the temp should be running at 210 but the rest of thinks it is running hot and I can't determine why.

Thanks for reading and I appreciate any input.

Thanks
Tiffurs
:frown2:

I agree that from what you're saying, you are running hotter than you should be. My '05 SSR runs just (left) of straight up on the temp dial. Can't remember what that straight up is without going out to the garage..........ain't gonna do that now. But I think it is closer to 180 or so.

The only time my needle gets straight up is in heavy traffic or I just shut 'er down and the auxiliary kicks in while I'm stopped.:smile2:

Yes, I have the Simple Engineering fan installed and also the aux. fan too.
 

·
Spirited driver!
Joined
·
1,536 Posts
My 06 runs 210 all.day long. This is normal.
 

·
Premium Member
Joined
·
1,954 Posts
  • Like
Reactions: BlueStreak

·
BAD BOW TIE
Joined
·
11,051 Posts
Mine runs 210 all day long.
 

·
Registered
Joined
·
1,065 Posts
Did the same thing as you tiffurs except replace water pump mine will run under 210 for a bit then go up to 220 back down to 210.....plan on having it tuned by Jeremy at Daytona see if that changes anything. Somebody said they run hotter then what we are used to seeing in order to meet emissions.
 

·
Registered
Joined
·
3,045 Posts
After changing all the hoses and water pump did you get the air purged out of the system? I had talked to Mike last week and he was telling me to be careful about making sure to get the air purged out of the system. Just a thought of what to look for.
 

·
Premium Member
2006 S/C Silver & 2006 Pac Blue 6spd
Joined
·
1,012 Posts
210 all day long (stock) in hot and humid Houston.

Side note: I recently installed new HD Radiator (due to jumping jack mishap), and SE-MFK-2 (a planned upgrade in prep for more “tweaks”) and the cooling system tune up, all from Simple Engineering. The radiator was unplanned, but required after closer inspection and Mike shipped it out the next day(!) and limited the unforeseen downtime to 3days. Thanks Mike!

I highly recommend all three. The radiator is a direct replacement from a Vette, the fan with Mike’s additional upgrades is from a Z06. They drop in and work great. It all belongs in an SSR and appears stock. I also replaced the hoses and flushed the and refilled the cooling system, per instructions per #30 here: http://www.ssrfanatic.com/forum/f5/green-verses-orange-antifreeze-58756/. The cap and thermostat are just “the right thing to do” when fiddling with the cooling system, ensuring the system continues to work properly.

Still 210 and more better.:grin2:
 

·
Premium Member
'06 FPR Smokin Asphalt; '04 Ulta Violet
Joined
·
4,379 Posts
tiffurs, With only 2 posts---Welcome from Forney Texas!!!-----Consider going to "Tools" in the red banner, click on "User CP" go to "Your Profile" then click "Edit Your Details". Then, whenever you "post" it will show in the left column under your name, like the rest of us, and we will know where you are and what you drive. Then if you have a problem, someone close by might be able to help out.

Nick & Kathy
 

·
BLU SSR
Joined
·
3,464 Posts
WELCOME tiffurs You are already ahead of the game since you have Mike's contact info -- don't lose it -- he will be your source for parts to maintain and upgrade your SSR in the future. Also consider becoming a Supporting Member , it makes traversing this site MUCH easier. :00000732::blur:
 

·
Slingshot Rules!
Joined
·
72,528 Posts
THANKS to Mike's Fan plus AUX Fan . . .

The Doophus has been running just South of 210 for years, regardless of the season or the outside temperature.

! :banana ! :cheers ! :banana ! :cheers ! :banana !
 
1 - 14 of 14 Posts
Top