Chevy SSR Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter #1
The cruise control wouldn't engage on the way home from a week in Myrtle Beach. Also felt that I had lost power. It ran good, but if I floored the pedal, nothing happened. It just very slowly gained speed. So now to research the problem. Great week and visits to Pier 14. Now to work on the R.
 

·
Premium Member
Joined
·
1,783 Posts
The cruise control has a switch that disengages the cc when the clutch is pushed in. It probably needs to be adjusted.:)
 

·
Registered
Joined
·
103 Posts
Discussion Starter #5
The Farris Wheel was great! I really enjoyed it all three trips around, but my wife was a little nervous the first round. We went in the middle of the afternoon and it was fully sunny and could see forever. They said it was 200 ft high. We had talked to a waitress at Pier 14 and she said at night wasn't as much fun as couldn't see very far. I'd recommend it to everyone! Also I would highly recommend Pier 14.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #6
I "flushed" the clutch fluid several times. It was pretty clean as I had done this when I first got the R in April. At that time the fluid was black! In Myrtle Beach, I noticed the clutch wasn't fully returning in the morning when it was cold, but after driving it awhile, it worked fine. Today after flushing the fluid, drove it and no clutch sticking and the cruise seemed to work. I did find the clutch switch, but didn't play with that. So all seems back to normal. Thanks for your responses though.
 
1 - 6 of 6 Posts
Top