Chevy SSR Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
1,015 Posts
Discussion Starter #1
I just installed the Eibach front and rears. The back came down about 1.5 as predicted, but I think that the front was only 1/2". (I didn't write down my "before" measurements :banghead ) Does anyone have the measurements either with the eibachs or the stock heights at whatever reference point you used. I was hoping to keep a little of the rake, but it looks pretty level, and actually is perfectly level measured on the running board with a level. Thanks
 

·
Registered
Joined
·
893 Posts
Thats funny....

6.0scSSR said:
I just installed the Eibach front and rears. The back came down about 1.5 as predicted, but I think that the front was only 1/2". (I didn't write down my "before" measurements :banghead ) Does anyone have the measurements either with the eibachs or the stock heights at whatever reference point you used. I was hoping to keep a little of the rake, but it looks pretty level, and actually is perfectly level measured on the running board with a level. Thanks

I installed only the rear Eibachs........and I still have a nice rake......something doesn't sound right here
 

·
Registered
Joined
·
1,015 Posts
Discussion Starter #4
2005SSR6Speed said:
You could always install the supercharger, that adds weight over the front.
Hey , but I thought the the S/C only added 6 lbs.:) Actually its in my future soon. I still need to drive one tho and am dying to see some track times.
 

·
Premium Member
Joined
·
9,353 Posts
When I measured mine before and after the Eibachs, the front did drop a full inch, back about 1 1/2".

Ray
 

·
Registered
Joined
·
1,015 Posts
Discussion Starter #6
Thanks, but

does anyone have the actual measurments on the front, before OR after. I might have screwed up my before measurment in my memory, i forgot to write it down... That is, I may have gotton the full drop , but am using the wrong reference.. Thanks again
 

·
Registered
Joined
·
436 Posts
Same problem

I used ground force springs and ended up with the front at the same height as stock but the rear was down and no rake. Drove it 500 miles hoping it would settle. Nope.

Called the factory......Double talk.......

Posted here.....no answers at that time......

Got help from member "Vetgirl"

Pulled the front springs back out, cut a full coil off and reinstalled. Drove it 100 miles and had it realigned. Rake is back and all is good.

Driving a Hot Rod
Skip
 

·
Registered
Joined
·
135 Posts
6.0scSSR said:
I just installed the Eibach front and rears. The back came down about 1.5 as predicted, but I think that the front was only 1/2". (I didn't write down my "before" measurements :banghead ) Does anyone have the measurements either with the eibachs or the stock heights at whatever reference point you used. I was hoping to keep a little of the rake, but it looks pretty level, and actually is perfectly level measured on the running board with a level. Thanks
I just lowered the back of mine and it measures 29" from the ground to the top of the wheel well.
The front is also 29" and I did not lower it. Still looks like it has a slight rake to it. That is the look I wanted.
 

·
Registered
Joined
·
1,015 Posts
Discussion Starter #10
then it's a mystery glitch

why my front came down only 1/2" to 28 5/8. We were careful to avoid bushing bind so thats not the problem. I looked at your pictures Sheldon, and could measure that the top of the wheel to the fender line was about equal on yours front and back. On mine , that measurement is actually slightly larger on my front, which detracts from the rake lines of the body.
Are your SSR's that you folks are referring to earlier than 05,s? Im thinking that chevy switched to Bilstiens in 05 (correct me if I am wrong) and may have changed some front end specs a little. Anywayys I have a call in to Eibach, for tomorrow, and will share anything I find out, in case someone else here runs into this same problem. Thanks for everyones help so far!
 

·
Registered
Joined
·
1,015 Posts
Discussion Starter #12
sheldon young said:
Any way you could have mixed the fronts with rears? They're labled 1 and 2 respectively.
Thanks Sheldon, but no. They're in the right place. I'll put it up on a lift this weekend to se if I can figure it out.. Still a mystery, and any other suggestions are welcome.
 
1 - 12 of 12 Posts
Top