Chevy SSR Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2,454 Posts
Discussion Starter #1
My emission control light came on today. I was zooming out to check the surf and then, when I stepped on the gas, nothing. I thought for a moment that Black Betty had stalled, but when I pulled over and goosed the gas pedal a few times, she began to function ok, but lacked the usual roar that we love so much in these trucks. On the way to the beach, she lacked any kind of power when I stepped on the gas. On the way back, the roar returned and so did the power, but it still seems limited compared to what she had. The light is still on. I was guessing it may be some lousy fuel I got that messed up the fuel filter or line, or perhaps the 02 sensor. Any thoghts from you who are more mechanically inclined would be appreciated. I am taking her in Tuesday for some top adjustment work but was hoping I could milk her along until then. :confused
 

·
A Little BIG JIM
Joined
·
3,351 Posts
Ed,
Could be as simple a a loose gas cap? We missed you at the DC to OC Cruise saturday...
lots of cars..............
BIG JIM
 

·
Registered
Joined
·
2,454 Posts
Discussion Starter #3
Missed you too budy! Looks like ya'll had a ball. I tried the cap, but the problem is definately something else. I just ran an errand and suddenly all of the power came back and the light went out. I think Betty must have had some indigestion from some kind of funky gas! I better be more careful what I feed her! :jester
 
0

·
Guest
Joined
·
0 Posts
THe Cap usuallt take 10-20 miles to reset the computer reading correct fuel pressure.
 

·
Registered
Joined
·
2,454 Posts
Discussion Starter #6
Light went out later. All is good. I will keep her until she returns to the dealer Tues. Weather is too good to pass it up. Saw a red SSR today and hooked up with him. A guy and his wife, lives in Chesapeake. Red SSR. That color looks so surreal coming up in your rear view mirror. Will have the dealer check this prob. out Tues.
 

·
A Little BIG JIM
Joined
·
3,351 Posts
Betty's Light Out!!

cruzned said:
Light went out later. All is good. I will keep her until she returns to the dealer Tues. Weather is too good to pass it up. Saw a red SSR today and hooked up with him. A guy and his wife, lives in Chesapeake. Red SSR. That color looks so surreal coming up in your rear view mirror. Will have the dealer check this prob. out Tues.
Ed,

Glad Betty's Engine light is out. We saw 4 Red,1 Silver,1 Yellow and 1 UV w/flames this
saturday......never seen so many on the road before!
 

·
Tu-Tone club member
Joined
·
5,780 Posts
Ed, maybe not out of the woods

just because the light went out.
Same thing happened to me last year. On a trip to So. Fla I stopped for an hour. Restarted and sputtering and missing galore. Step on the gas....didn't want to run. Finally seemed to run better, then finally all appeared normal. Light went out also.
Drove back home...560 miles...gas mileage went in the toilet...went to the dealer...check for misfires in the PCM....over 900 read from the left front O2 sensor. Replaced it. Made a big difference from the previous performance.

With that situation, the PCM resets the engine to a default running condition to make it run as good as possible. Kind of scary when it first happens though.

P/P

Peace :flag
 

·
Registered
Joined
·
2,454 Posts
Discussion Starter #9
THanks Penelope! It was scarry! I am taking her in tomorrow afternoon. Hopefully nothing will happen in between to cause more trouble.
 

·
Registered
Joined
·
2,454 Posts
Discussion Starter #10
Today on the way home, the beast lost power, but no emission control light. She is clearly loosing power. Hope I get her to the dealer in the afternoon afterwork tomorrow without incident. :mad
 

·
SSR Pit Crew
2004 UV
Joined
·
9,315 Posts
emission control light on

Picked up the :ssr on Thursday after having cooling fan and A/C worked on. Pleased to announce that the hood blanket had NOT been damaged like so many others had. BUT...Friday morning as I started to run errands I noticed that the engine light was on. Wasn't quite sure what it was, so RTFM, followed the suggestions: reset gas cap, had not gone through any puddles, and have not changed fuel brands unless the dealership/service dept put something strange in it but I did fill up on the way home. :confused :confused Finished my errands and drove home, 22 miles...light still on.

Did notice on Thursday when I picked it up that it didn't sound like it normally does but thought it was my imagination and it didn't seem to have any power differences when driving. If light still on Monday, on my way to work, back to the shop it goes :cuss It is possible that the light was on when I picked it up but it is located in such a position that it is not easily noticed...
 
1 - 11 of 11 Posts
Top