Chevy SSR Forum banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
2,320 Posts
Discussion Starter #1
Well,
I have had the first service performed on my 05 # 21290.
Oil Change, went to Mobil 1 synthetic.
Had some shimying and slight shaking going on at front end at 45 MPH to 65MPH,
and then smooth over 70MPH. Turned out to be bad balance job from factory, and too much air pressure in all the tires.
Also had some black tape coming off of the wiring harness. I suppose that the tape they used at the factory must be the type you may buy in discount stores or something.
All in all, very happy with items and service performed. I will be returning to the Dealer to have the plastic rear fender cover re-set, as the double sided tape under it appears to be coming loose. I don't think they took into account the intense heat on the roadways here in Arizona.

:flag
 

·
Registered
Joined
·
185 Posts
I was leaving the Library for lunch yesterday and a silver with chrome pulled out of the ASU parking lot as I went buy. Library is a great place for lunch.
 

·
Premium Member
Joined
·
2,320 Posts
Discussion Starter #5
Library

Have you signed on to the AZ page? We have our own AZ SSR web page, check it out.
I wish I had time yesterday for a lunch over there. My office is near Mill & Baseline

One more item:
After service today at the dealership, I discover the Maint. record book is not in the car. At the same time I get a call from the Service Writer, telling me that he aciddentally left the book on his desk, "Can he bring it to me after work?"

An excellent example of follow up service, something that I have been so fearful of not getting.

Proof that Service is still out there. Try Bill Heard Chev. for your services.
Ask for Jeff.

:flag
 
1 - 5 of 5 Posts
Top