Chevy SSR Forum banner

1 - 9 of 9 Posts
C

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Does anyone know how to replace the front turnsignal lights. Have 04 with one lamp burned out. Any assistance would be greatly appriciated.
Mike:cool
Semper Fi
 

·
Banned
Joined
·
2,141 Posts
Look in your owners manual, I know the silver chevron bar has to be removed to change them. I think there are two screws once the hood is open. You remove the screws and that whole bar pulls off. Read the manual however.
 

·
Jim-n-Tanya
Joined
·
1,354 Posts
Turn Signal removal

First Read the drivers manual. Just kidding...........

Find yourself a plastic knife and push on the tab of the lamp.
depending on which one you are changing your left lamp you need to push in with the knife on the right side. The right lamp you need to push in on the left side. Your lamp should just pop out. Just the housing of course. Then pull out the housing and twist the lamp out through the back of the housing.


Hope that help I had to do it twice to put in strobe lights.


L8ers
 

·
Registered
Joined
·
1,502 Posts
Yep! It's all there, pictures and everything.

However, if it's still under warranty... Don't :banghead
 

·
Premium Member
Joined
·
6,371 Posts
Turnsignals

Got my early 03 SSR out of storage today. Did a safety check before I took it on the road. Checked out the Turn Signals, both right and left. They would start to flash a few times, then just stop working all together! Both sides.
Anybody else have this problem happen to their SSR? :nodno
 

·
Registered
Joined
·
10,950 Posts
Scott 0168 said:
Got my early 03 SSR out of storage today. Did a safety check before I took it on the road. Checked out the Turn Signals, both right and left. They would start to flash a few times, then just stop working all together! Both sides.
Anybody else have this problem happen to their SSR? :nodno

I had the turn signal get stuck on twice. I turned the signal off and then back on and it worked fine. I just chalked it up to the gremlins in the system. After 68,000k+ miles I only remember it happening twice.
 

·
Premium Member
Joined
·
6,371 Posts
Safety Percaution

Thanks for the info! I was going to call my Service Rep. today. As you know its really hard to tell if your turn signals are working because its hard to see the arrow lights in the insturment cluster when you are driving!
To be on the safe side I would recommend everyone to do this safety check! :)
 

·
Registered
Joined
·
596 Posts
WOW_FCTR said:
I had the turn signal get stuck on twice. I turned the signal off and then back on and it worked fine. I just chalked it up to the gremlins in the system. After 68,000k+ miles I only remember it happening twice.
Mine did the same thing and then quit. The dealer couldn't find or duplicate the problem. Now it's fine. What's up with that?
 
1 - 9 of 9 Posts
Top