Chevy SSR Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
10,950 Posts
Discussion Starter #1
My SSR is sitting in a stereo shop right now. I am unable to bring it home.
I was hoping that someone out there might be able to help me with this problem.

Situtation:
1) The top is most of the way down, but now refuses to move in either direction. It sounds like there is no signal going to the hydraulic pumps because there is no sound.

2) I can not take the key out of the ignition. Can anyone take there key out if the top is only halfway up or down?

The things that were done at the shop:
1) installed remote radar detector
2) installed XM radio and
3) we applied some felt on the lip under the plastic water fall behind the seats to quiet the rattle from the base.

After the shop closed for the evening, I thought that maybe there was some sensor on the lip that tells whether the top is opened or closed, but can't find anything.

Is there a reset button for the top? I turned the car on/off, moved the shifter from park to neutral to first, I've hit the brake. I've done everything I can think of.
There are no messages in the DIC. The car starts and shifts fine.

I'm really baffled here and any help would be appreciated as I won't be able to drive the SSR until this is fixed...


And for those of you who told me not to jinx myself with the tire comments.... I found another screw in one of my tires. It must have been there a while because it is worn, but the tire still has full pressure. I guess the first place I drive tomorrow, if I get the top working again, is the tire place.

John
 
J

·
Guest
Joined
·
0 Posts
maybe some help

i might be able to help please call its much easier......407 702 4872\

my name is jeff
 

·
Registered
Joined
·
1,502 Posts
The only time I haven't been able to get the key out, is when the tranny was out of park.

PS: As far as the top go's. I suppose it's possible the top position vs switch positions is out of sequence in the computer that controls this. I'd suggest following the instructions in the owners manual to raise or lower the top manually. Then pull the battery cable so all the computers loose power and reset.

PPS: I spent the last 2 hours digging thru the service manual.

Your SSR is at the installer having XM radio put in. Do you have the factory head unit disconnected? The attached schematic seems to show that the RDM (roof door module) connects thru the radio. (Can any one verify this?) If that is so, then the factory radio, or an adaptor has to be attached or the roof won't operate. Other things like warning chimes won't work either.

I also read the inoperative top diagnostic proceedure.

It's complicated. A scan tool is needed to completly diagnose top problems. There are ~20 steps.

Was the battery disconnected? The RDM (roof door module) can loose data if power is lost.

One item that can be lost is the zero position of the windows. If power is lost, then restored, the current window position becomes the Zero position.

It's part of the diagnostic procedure to rezero the windows. (step 3)
Code:
    Close the doors.
    Drive the window full up till it stalls and hold for an additional 1/2sec.
    Drive the window full down till it stalls and hold for an additional 1/2sec.
The way the procedure is written this might be all that is needed.

Everything else is testing to find faulty electrical/mechanical stuff.

I saw no mention of the top having a zero position, like the door windows.
 

Attachments

·
Registered
Joined
·
10,950 Posts
Discussion Starter #4
response

Glenn and Jeff,

Thanks for the responses.

The radio was not even touched. The XM was installed using an FM transmitter.
I'll have to ask it the battery was disconnected at all (I would guess he did, but don't know)

I will be returning to the installers this morning at 9:30 when they open. I'll let every one know what the problem was so that they don't do the same thing.

John
 

·
Registered
Joined
·
2,454 Posts
Whoa....John....this has got to be a nightmare for ya buddy. Hope you can resolve it and let us know how it was done. I thought my previous top probs. were a bummer but yours are soooo sad. After they adjusted my top, it has worked flawlessly and I put it up and down a lot! Hope they can do the same for you. Jeff really knows his stuff too. Listen to him.
 

·
Registered
Joined
·
10,950 Posts
Discussion Starter #6
diagnosis

This morning when I got to the installers, he had come in early to try and diagnose the problem. He did find that the Ignition fuse keeps blowing, but didn't know why. He had disconnected everything that he installed yesterday, but that didn't keep the fuse from blowing. So after a couple of hours, I just decided to drive it back to the dealership. We manually put the top down and I drove it back. during the drive I noticed that the transmission wasn't shifting correctly and the engine light was now on. I got to the dealer ok and they will be checking it out Monday.....

I was reading in the SSR book from AQ how the SSR actually has a computer network that sends messages, not just electrical currents, to components. That plus the fact that the radio controls more than just your stereo is amazing and I see how this can be a real nightmare for any aftermarket installer.


I'll let everyone know what the problem was and what the final costs were when I find out....just so that you can consider those facts when deciding on upgrading your electronics on this vehicle....
 

·
Registered
Joined
·
2,454 Posts
How hard was it to manually lower the top Jon? I bet it took some time eh? I would really like to know what to expect when that need arises some day.
 

·
Registered
Joined
·
10,950 Posts
Discussion Starter #8
lowering the top

It wasn't hard for me as the only thing I had to do was lower the flapper panel, the two roof pieces were already down. I just had to pull the 2 green cables, apply pressure on the flapper panel, which went down very smoothly. Then I pulled the red cables which locked it into place. The reason I decided to put it down rather than up was to avoid trying to figure out how to get the roof clamps to grab once the roof was up.....
 

·
Registered
Joined
·
2,454 Posts
John: What is the status on your SSR? Has the dealership found out how to fix it or what caused the trouble?
 

·
Registered
Joined
·
10,950 Posts
Discussion Starter #10
Status

The dealership found that the amp (which had been installed for 4 months already) was causing the short. It took them $250 worth of their time to figure it out and cut the offending wire. I haven't had time to take it back to the installers to have them correct the problem.

The good news is that the XM radio and radar dector install is working good and looks great (pictures when I get everything fixed). I'm also going to try and find a nice way to install an auto kit for the new GPS Navigation PDA I just bought.

I had no idea that when I spent 50k to buy this truck that I would keep spending money on it like it was growing on trees. I still have to decide on what kind of paint protection for the hood and bumper to add...maybe I should have done this first as I've already put 10,000 miles on and have a nice rock chip to show for it.
 

·
Registered
Joined
·
10,950 Posts
Discussion Starter #11 (Edited)
XM and radar install

Now you see it now you don't (or vice versa if the pictures load the other way).

This is where we stuck the XM controller and radar dectector. The radar detector is a remote with radar, laser and a temperature probe. Both will work whether the compartment is open or closed.
 

Attachments

·
Registered
Joined
·
10,950 Posts
Discussion Starter #12
Unknown Object

During the install, we found this unknown object above the ash tray inside the compartment where the ashtray closes. Actually had to remove it (it was held in by a plastic clip) for the XM controller to fit. Anyone have any idea what it is?
 

Attachments

·
Machell
Joined
·
20,829 Posts
In the name of science, :jester heee heee heee :lol , well not exactly but for my own curiousity I had to go crawl under the dash and have a looksee, and sure enough there it is the ufo. I twisted and turned it but it didn't come out, it actually seem to snap into place when I pushed and pulled on it, like a button. Maybe it is just a cute plug for some future add on in the dash. How did you actually get it out? and it looks silver in the picture put it is black plastic. :confused
 

·
Premium Member
Joined
·
2,664 Posts
Looks like to me....

wildcat66 said:
In the name of science, :jester heee heee heee :lol , well not exactly but for my own curiousity I had to go crawl under the dash and have a looksee, and sure enough there it is the ufo. I twisted and turned it but it didn't come out, it actually seem to snap into place when I pushed and pulled on it, like a button. Maybe it is just a cute plug for some future add on in the dash. How did you actually get it out? and it looks silver in the picture put it is black plastic. :confused

that one of the robots gave us "the finger."
 

·
Registered
Joined
·
10,950 Posts
Discussion Starter #18
Made you look

Let's play a game with the UOs. Write your name and location on it and the next time you see another SSR trade your UO with their UO. Then when you get a UO from a place you always wanted to visit, drive there and return the UO to it's owner. :lol

(My UO was a grey in color not black...)
 

·
Registered
Joined
·
10,950 Posts
Discussion Starter #20
Ordeal over???

I just picked up my SSR from the stereo install shop which finally fixed everything and now the truck sounds great.

Later this week I'm having the GPS installed.....or should I get out while I'm even?

Instead of putting in all this electronic equipment in, I should have put one of the paint protectors on :mad as I now have 4 rock chips in the hood. That comes out to be 1 chip every 2500 miles (in case some of you were wondering when you'd get your first rock chip). Looks like I'll be spending more money, more money, more money....but I'll be smiling when I do. :)
 
1 - 20 of 23 Posts
Top