Chevy SSR Forum banner

21 - 34 of 34 Posts

·
BlueStreak
Joined
·
27,160 Posts
You will find that it is easier to work with the pump and reservoir with the top up once you get the lid open. Just a suggestion.
 

·
Registered
Joined
·
16 Posts
I had a similar problem with my '04. "Roof Cycle Timeout" message was displayed. Dicktator's advice solved my problem. It was a very small microswitch that was sticking. I applied some WD-40 Silicone spray and exercised the switch to loosen it up. Fixed my issue. You will have to partially remove the actuator assembly to gain access to the switch. Dicktator's OneDrive website is a wealth of information and it gives instructions as well as pictures. He's a lifesaver!!
 

·
Registered
Joined
·
40 Posts
Discussion Starter #23
Yes he is, but your comment begs one more question...where is the actuator assembly located. It may be in the pictures and other info. Obviously I haven't done anything yet...getting my ducks in line.🙂
 

·
BlueStreak
Joined
·
27,160 Posts
Yes he is, but your comment begs one more question...where is the actuator assembly located. It may be in the pictures and other info. Obviously I haven't done anything yet...getting my ducks in line.🙂
Go to the One-Drive and look through the power point. You will learn what you will need and have an idea of what you are getting into, or what you want your mechanic to get into. It will answer your questions before you get started and save a bunch of questions and mistaken answers here.
 

·
Registered
Joined
·
1,935 Posts
Once you open the roof cover and it is in the fully up position and before the top starts down you can look on each side and see a panel. It has 4 bolts that hold it in place. The panel has to be pulled up before it comes out and it is not a simple remove the bolts and it falls out of the way. It takes a little pulling to get it out. Go over the instructions in Dicktators write up and you can get through it pretty easy then. I may have time next Saturday to help you if you need it. I know Sunday my wife has me going to pick up something for her in the other direction.
 

·
Supporting SSR Hobbyist
Joined
·
9,575 Posts
OK....... I’m a little confused here. I see a lot of solutions and direction offered, but not a clear problem statement or any troubleshooting to root cause. Everything from a microswitches issue to a hydraulic reservoir fluid level and hydraulic cylinder repair has been touched on... but........

What is the exact problem? What are the symptoms?

Lets get this fixed without working on stuff that isn’t broken......

Mike
 

·
Registered
Joined
·
1,935 Posts
Mike I think the top stopped working and he is asking some basic questions to get ideas of where to start and what to look for. I agree it would be best if he starts with a base of what is working and at what point it stops working and what is the last thing that happened to start the diagnosis from there.
 

·
Supporting SSR Hobbyist
Joined
·
9,575 Posts
Mike I think the top stopped working and he is asking some basic questions to get ideas of where to start and what to look for. I agree it would be best if he starts with a base of what is working and at what point it stops working and what is the last thing that happened to start the diagnosis from there.
The first questions should be:
  1. Is the top stuck up or down?
  2. With the windows up, what happens when the button is pushed?
  3. Do you ever hear the pump run?
  4. Does the tonneau cover unlatch?
Once we figure out what is and what is not working, we can start heading for what is causing the issue.

Mike
 

·
Registered
Joined
·
40 Posts
Discussion Starter #29
To all that replied recently, I haven't started to work on it yet or even tried any of the suggestions. I will let everyone know when I finish what the problem was. I think I have all of the possible cures. Thanks again to all for your knowledge and support. R, Don
 

·
BlueStreak
Joined
·
27,160 Posts
Follow Mikes steps and do not try to out guess the results. come back with the answers and let us help. Many of us have been there before and can help and save time chasing bad trails.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #31
BlueStreak,
Thanks again for the support. I will let everyone know the outcome of my work on the top. Still in Florida w/o my SSR and missing it.😎
 

·
Premium Member
Joined
·
4,510 Posts
I am confused. Post #3 says your in Central Illinois. Post#6 you said (10 days ago) said you will be available Thursday. Post# 31 says your in Florida w/o your SSR. My first question would be, when you push the top button do you hear the latches release and then the pump running?
 

·
Registered
Joined
·
40 Posts
Discussion Starter #33
Ok sorry I've been away. I live in central Illinois (metro St Louis). The comment about being available Thursday was in response to Stlhotrod about helping me. I was in Florida for 10 days w/o my SSR (wasn't allowed to be checked in as luggage on the airplane). Does that clear things up? In answer to your question is no...no noise from latches. I think everyone's responses have me zoned in on the problem. Thanks for responding.
 
21 - 34 of 34 Posts
Top