Chevy SSR Forum banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
3,695 Posts
Discussion Starter #1 (Edited)
Hello
I have reasonable mechanical talent, however I'm having an issue installing the MGP Caliper covers.
Can not seem to get the passenger side front to tighten up, bottom tightens, top won't , I have had it on and off several times, reviewed instructions , watched Utube and still no go, very loose on one end.
Any ideas on what I might be doing wrong ?
 

·
Premium Member
2006 Pacific Blue 6 speed Custom
Joined
·
3,317 Posts
Gosh, wish I had an answer for you.... Hope you get it figured out. Love mine!
 

·
Ex SoCal Nut
Joined
·
9,920 Posts
make sure the nut threads are snug all the way down the all-thread. you may have an oversized nut there. you can tighten that one down First and then slide the clip bracket all the way down the caliper until it's bottomed out and then run the front nut down. is that the only one giving you grief?
 
  • Like
Reactions: shakatak

·
My First Permagrin !
Joined
·
567 Posts
Hello
I have reasonable mechanical talent, however I'm having an issue installing the MGP Caliper covers.
Can not seem to get the passenger side front to tighten up, bottom tightens, top won't , I have had it on and off several times, reviewed instructions , watched Utube and still no go, very loose on one end.
Any ideas on what I might be doing wrong ?
When installing my covers I couldn't get the fronts to stay tight ,
They kept sliding in and out , I tried bending the clips but it made it worse .
So I put a piece of Velcro between where the caliper and the cover touch .
Worked great ! Stayed tight no rattling . Dave
 

·
Premium Member
Joined
·
3,695 Posts
Discussion Starter #5
Hey Jersey Red
Did you put the Velcro on where the clip and calipers touch/rest to the side of the cover against the caliper ?

Any info will help.

Yellow Bear
No issues with the other 3,but took them off until I can fix the issue with front passenger one.
 

·
Super Road Rocket Pilot
Joined
·
6,222 Posts
As I remember installing a kit, the clips are C or U shaped. Have you compared the loose side clip formation to ones that fit tightly? I think if you adjust (bend both outer sides to make distance between the C opening smaller) it should grab better. I would be similar to added a spacer or the velcro. The stainless clips are rather a weak design, it would not take much to make one just a hair too large to allow slop in the installation. Maybe swap clips from a good side to a bad to prove that it is a clip issue and to from there????

You could use some high temp RTV, good up to 650, brakes get to maybe 400, to help adhere the clips to the caliper frame. It would make the installation pretty solid.

Good luck!
 

·
My First Permagrin !
Joined
·
567 Posts
Hey Jersey Red
Did you put the Velcro on where the clip and calipers touch/rest to the side of the cover against the caliper ?

Any info will help.

Yellow Bear
No issues with the other 3,but took them off until I can fix the issue with front passenger one.
Yes I put the Velcro between the caliper and the cover then the clip on top ,tighten the nut and good to go .
That took me 2 tries and a lot of shaking my head before the Velcro idea . It works for me . Dave
 
1 - 8 of 8 Posts
Top