Chevy SSR Forum banner
1 - 13 of 13 Posts

· Premium Member
2004 SSR 5.3 Automatic Ultra Violet
Joined
·
16 Posts
Discussion Starter · #1 ·
Carefully following the directions I found on this site I jump started my 04 SSR.

It started right up, however now I have ABS and Airbag lights on the dash...along with low batter indicator AND
Top, windows, door locks, are not functioning.

I also realize my manuals are in the bed saddlebag...

Any suggestions on where to start looking for fuse or relays would be appreciated. Hoping I haven't toasted the RDM...

Thank you in advance.

Max
 

· Premium Member
2004 SSR 5.3 Automatic Ultra Violet
Joined
·
16 Posts
Discussion Starter · #3 ·
Carefully following the directions I found on this site I jump started my 04 SSR.

It started right up, however now I have ABS and Airbag lights on the dash...along with low batter indicator AND
Top, windows, door locks, are not functioning.

I also realize my manuals are in the bed saddlebag...

Any suggestions on where to start looking for fuse or relays would be appreciated. Hoping I haven't toasted the RDM...

Thank you in advance.

Max
You have blown the 125 amp fuse, in the Under Hood Fuse Box - a common jump start issue.
‘Also check the radio, after replacing the 125 amp fuse, if the radio lights up but you have no sound check the 25 amp amplifier fuse in the rear fuse box.
Can you advise which is the 125 amp fuse...Is it the black one which is different from all of the rest? Thanks!!
 

· Premium Member
2004 SSR 5.3 Automatic Ultra Violet
Joined
·
16 Posts
Discussion Starter · #4 ·
Can you advise which is the 125 amp fuse...Is it the black one which is different from all of the rest? Thanks!!
After referring deeper into this website I find the location. Thanks...I will let you know if this is the fix for me. Again, thanks for your prompt response!!
 

· Premium Member
Joined
·
1,923 Posts
Carefully following the directions I found on this site I jump started my 04 SSR.

It started right up, however now I have ABS and Airbag lights on the dash...along with low batter indicator AND
Top, windows, door locks, are not functioning.

I also realize my manuals are in the bed saddlebag...

Any suggestions on where to start looking for fuse or relays would be appreciated. Hoping I haven't toasted the RDM...

Thank you in advance.

Max
Perhaps someone will clue you in to open trunk
for manuals...privately!!!!
 

· Premium Member
2004 SSR 5.3 Automatic Ultra Violet
Joined
·
16 Posts
Discussion Starter · #11 ·
Thank you everyone who responded to help. Did a charge on the battery and fired up right away and everything seems to have reset and be functioning properly. Will put a trickle charger on it. I did have battery checked and it is OK...just been sitting too long I guess. Again, Thanks to all.
 

· Slingshot Rules!
Joined
·
90,808 Posts
Thank you everyone who responded to help. Did a charge on the battery and fired up right away and everything seems to have reset and be functioning properly. Will put a trickle charger on it. I did have battery checked and it is OK...just been sitting too long I guess. Again, Thanks to all.

Remember, Max . . .

Battery Tender vs Battery Trickle Charger . . . HUGE DIFFERENCE !

! :cool: ! 👍 ! :cool: ! 👍 ! :cool: !
 

· SSR Believer
Joined
·
4,219 Posts
Thank you everyone who responded to help. Did a charge on the battery and fired up right away and everything seems to have reset and be functioning properly. Will put a trickle charger on it. I did have battery checked and it is OK...just been sitting too long I guess. Again, Thanks to all.
Well done! (y) Be sure you're putting it on a battery tender/maintainer to keep the battery in top shape. Although they are sometimes referred to as a "trickle charger", they are not the same thing and an actual trickle charger can do damage since they never stop charging. More here:

 
1 - 13 of 13 Posts
Top