Chevy SSR Forum banner

1 - 11 of 11 Posts

·
Machell
Joined
·
20,829 Posts
Discussion Starter #1
On the passenger side the bar is seperated from the light.

What is under the bar to hold it in the groove?

Is the two bolts the only think holding it on, or are there clips under there too?
Thanks for any help!:cool
 

·
OP
Joined
·
8,226 Posts
Velcro

I believe Velcro holds it in place mainly, push hard on it and it should seat, mine did this early on but I just muscled it back into place and have had no problems since.
 

·
Machell
Joined
·
20,829 Posts
Discussion Starter #3
I did push it back in, that didn't fix it. I wasn't sure if it was just velcro under it or what! There is a large gap, the other side is great!
 

·
Registered
Joined
·
1,502 Posts
Try loosening the two screws that hold it on before pressing it back in place, then retighten same.

Alternatly the adhesive holding one side of the velcro in place may have let go. I'd see the dealer or a body shop for that problem.
 

·
Premium Member
Joined
·
17,317 Posts
Try slowing down to sub-light speed, and maybe the pieces of your car won't come off :glol :glol :glol
 

·
Registered
Joined
·
893 Posts
Drunk?????

Sounds like your Bar had to much to drink over the weekend.....:glol :nono ...Truthfully.....sounds like time for a new velcro kit.....the backing may have come loose...:seeya
 

·
Registered
Joined
·
442 Posts
shorter bar

Off topic, but related.........whitewolf, please describe how you shortened your bar, removing bowtie, etc. I asked in a seperate post but got no response. thnx!
 

·
RetroCarGuy530
Joined
·
1,614 Posts
My 03 SSR had the same problem with the chevron bar coming off at the front passenger light. I ended up removing the bar and replacing the factory velcro with some "industrial" velcro from home depot. That fixed it.

It seems the factory velcro will not always retain its ability to "stick" to the corresponding piece on the chevron bar.
 

·
Machell
Joined
·
20,829 Posts
Discussion Starter #11
I figure as many times as it has been washed the velcro came loose!! But I wanted to make sure there weren't any hidden clips. Thanks I will pick up some velcro!
 
1 - 11 of 11 Posts
Top