Chevy SSR Forum banner

1 - 10 of 10 Posts

·
Premium Member
Joined
·
726 Posts
Discussion Starter #1
Had this come up. The left turn signal works just when the lights are off. When the headlights come on,it blinks faint and fast. Switched bulbs around and it works fine on the other side. Other bulb blinks fast and then fine when the lights are off. Question is does this sound like a ground problem?. Thanks
 

·
Registered
Joined
·
2,992 Posts
Could be. There are several threads about checking grounds on the trucks. Might want to do search for them and do some checking on your truck.
 

·
One of the SoCal Nuts
Joined
·
28,400 Posts
I would say it sounds like a ground problem. Good luck in your search.
 

·
Premium Member
Joined
·
726 Posts
Discussion Starter #4
It's what I think too. I'm out of town down in Dallas. I'll do a search and try to find a thread where someone posted the ground locations and what was grounded where. I drove my big truck down here. More bigger to protect me from all these crazy driving Texicans.Thanks guys.
 

·
SSR Pit Crew
Joined
·
12,670 Posts
It's what I think too. I'm out of town down in Dallas. I'll do a search and try to find a thread where someone posted the ground locations and what was grounded where. I drove my big truck down here. More bigger to protect me from all these crazy driving Texicans.Thanks guys.
You could try SSR How to Library: https://onedrive.live.com/?id=3EF39D9F5ADCE5E5!853&cid=3EF39D9F5ADCE5E5

Look up ELECTRIC GROUNDS and MUTI-FUNCTIONS SWITCH.

I think it is Multi-Function Switch.

Dicktator
 

·
Premium Member
Joined
·
726 Posts
Discussion Starter #7
Will do when I get back home. Thanks again
 

·
Premium Member
Joined
·
2,889 Posts
I would say it is a ground not a multi function switch. The headlights would not have an effect on bad multifunction switch.

NOTE: I have seen bulbs that look good but the little wire on the base of the bulb has a worn sport and doesn't always fit the socket properly if socket is a little loose.

Does it act up only with headlights on or will it act up with light switch turned to park light setting? --

If acts up with park lights only ---Turn on park lights and hazard lights -- check the intensity of the bulbs comparing the left side to the right side both front and back - it could be your rear turn signal/taillight. You should notice left front or rear is not as bright as right side -- one that is dim is where you need to start.

Assuming its the front here are some suggestions.

Does the left headlight seem to not be as bright as right side? high and low beams should both be affected and will be worse with AC on and engine running (G100 also grounds fuel pump and AC compressor relays).
If yes check G100, if no then its bad ground for park/turn signal bulb or socket.

It would be best to test grounds using a voltmeter. With park lights and turn signals on -- Connect black lead to a good ground, back probe (do not disconnect socket) connect red lead to black wire - should measure about .5v or less -- if 0.0 volts you do not have a good connection. If larger than about .5 you have a bad ground. If G100 is ok -- splice a new ground wire from the black wire to a good ground or check at C107.

If less than .5v check power side --
move red lead (again backprobe) Red/orange should be steady close to 12v. Then check green wire should be flashing 0-12-0-12 etc. your meter might average at 6 volts depending on speed of meter. If readings are good bad bulb or socket.

Left front turn signal and park lights both ground at G100 -- see diagram
Left Headlight also grounds at G100

If problem in rear -- same procedure -- wire colors will be different

G100 at lower left of engine - #11 in second diagram

Hope this helps let us know what you find
 

Attachments

·
Premium Member
Joined
·
726 Posts
Discussion Starter #9
Well the bad news is my BIL passed yesterday.They were just up here five weeks ago when the better half passed. Was fine then. Funeral isn't until next Tuesday.I came home this morning for a couple of days.Decided to try and run this down.I can't lay under and look up,makes me real sick to my stomach. I ran a wire from the black wire at the socket and it works great. Nice and bright and blinks like it should. I know that doesn't correct the truck ground,but I did see a broken black wire close to where the turn signal plugs in. It didn't seem to come out of the loom.I'll get a buddy of mine to look at it. Everything else works good.Thanks for the suggestion of running another wire.:grin2:
 
  • Like
Reactions: Autoprof

·
Premium Member
Joined
·
2,889 Posts
Well the bad news is my BIL passed yesterday.They were just up here five weeks ago when the better half passed. Was fine then. Funeral isn't until next Tuesday.I came home this morning for a couple of days.Decided to try and run this down.I can't lay under and look up,makes me real sick to my stomach. I ran a wire from the black wire at the socket and it works great. Nice and bright and blinks like it should. I know that doesn't correct the truck ground,but I did see a broken black wire close to where the turn signal plugs in. It didn't seem to come out of the loom.I'll get a buddy of mine to look at it. Everything else works good.Thanks for the suggestion of running another wire.:grin2:
Sorry to hear of your loss.:angel

Great job working with the information I provided:rock:

May I suggest that you put the top down load your favorite sing along cruising music CD and go for drive on your favorite scenic route.

It always helps me whenever I feeling a little down or just need to get away from it all.

Again you did great! Glad I could help!
 
1 - 10 of 10 Posts
Top