Chevy SSR Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
421 Posts
Discussion Starter #1
Well, I got my fan replaced by the dealer. I confirmed that both the low speed and the high speed are working. I dropped-in a 160 Degree Thermostat. Finally, I topped-off the coolant with a 50/50 mix of Dexcool and water.

Now, my SSR runs at a normal operating temperature of between 185 and 190 on the highway and 200 to 205 in stop and go traffic. And, that is here in Tampa, Florida where the temp was 93 with a "feels like" temp of 100.

We'll see how long it lasts.

Matt
 

·
Premium Member
Joined
·
1,783 Posts
160 deg Thermo

Where did u get it? Part #?
 

·
SSR Pit Crew
2004 UV
Joined
·
9,315 Posts
matjow said:
Well, I got my fan replaced by the dealer. I confirmed that both the low speed and the high speed are working. I dropped-in a 160 Degree Thermostat. Finally, I topped-off the coolant with a 50/50 mix of Dexcool and water.

Now, my SSR runs at a normal operating temperature of between 185 and 190 on the highway and 200 to 205 in stop and go traffic. And, that is here in Tampa, Florida where the temp was 93 with a "feels like" temp of 100.

We'll see how long it lasts.

Matt

Wonder how this will effect emission check here in good ol' CA. Would like to do this as well because it really makes me nervous after the last fan failure and the high temps we have had this year (110+)...especially nervous since I seem to be watching the gauge more than the road :lol
 

·
Registered
Joined
·
421 Posts
Discussion Starter #4

·
Premium Member
Joined
·
1,783 Posts
Artsmart, when you go for your smog test, put the stock one back in.
 

·
Premium Member
Joined
·
1,783 Posts
Thanks!

I just ordered mine. This has always been a performance mod for the Camaro.
 
1 - 6 of 6 Posts
Top