Chevy SSR Forum banner

101 - 120 of 125 Posts

·
Daily Driver
Joined
·
8,897 Posts
Glad you're making progress, Doc. :thumbs
Having to fix things is a pain in the wallet, but not being able to figure out what to fix is hell.
 

·
Premium Member
Joined
·
133 Posts
Hi To Anyone and everyone. I heard a noise when taking down the Top so since I have never had to oil it I'm guessing it is time, so can someone please tell this Dumbass what should be lubed and with what kind of lube Thank you. And please don't laugh at me because I represent this comment.
 

·
Premium Member
Joined
·
2 Posts
Problem with driver side lights.

I replaced bulbs and 1 10 amp fuse but lights still won't come on on drivers side rear taillight and license plate light. Can you tell me what else I could try. The lights worked before I replaced bulbs and blew a fuse.
 

·
Registered
Joined
·
79 Posts
Ed, I have a friend that has an SSR but not on the fanatic site. The car is new to him and he hates computers. He wants the main fuse box fix installed. His car stops running and he needs to tap on the fuse box to get it going. He would like to send the unit to you. You did mine at the Springfield, IL rally.

If this is something you would be interested in doing, let me know. If you could PM me with info then I'll pass it on. That way he can contact you directly.

Thanks,
Tom (clemenza)
 

·
Registered
Joined
·
47 Posts
Hey Ed, if you're out there listening ... I posted another thread, http://www.ssrfanatic.com/forum/f5/need-some-help-i-m-0-2-ssr-won-t-start-229481/#post3946938 concerning my 04 SSR, thought I had her fixed only to find her dead as a door nail this morning... brand new red top battery is completely discharged, hooked her up to a charger and there's a lot of resistance.

Wondering if any of this is making sense... I think she's got a short some where, causing the battery to completely discharge. I can't explain why I can't even jump her (yes I get a good ground to the engine block and yes all the gauges are showing electrical flow) but when I crank her over, I don't even get a click for the starter. Is it possible that the Ignition Switch went out again? What would cause a new battery to completely discharge?

Thanks!

Al (omg_its_al)
 

·
Registered
Joined
·
13 Posts
Hi Ed, Are you the guy that replaces step motors in a gauge cluster? If so would you do a 2003 express 1500 van? I hope I remember correctly, gettin old ya know.

Jim
 

·
Registered
Joined
·
17 Posts
I have tried to PM Ed in Fl but I don't yet have 15 posts. I sure wish I could speak to someone who is knowledgeable on SSR engine electrical. I may have to take it to a dealer to see what they can do. see post "Hot no Start"
 

·
Registered
Joined
·
12 Posts
Quick question on tach and temp gauge reading hi and not coming down. Turned off for one hour and turned back on. Did not reset still showing hi not resetting. Any thoughts?
 

·
One of the SoCal Nuts
Joined
·
28,016 Posts
Quick question on tach and temp gauge reading hi and not coming down. Turned off for one hour and turned back on. Did not reset still showing hi not resetting. Any thoughts?
Bad stepper motors. Replace them all. See Dicktator's One drive
 

·
Premium Member
Joined
·
2,461 Posts
Mice have gotten to my wiring. Insurance will pay for neww wiring harnesses. Where is a good place to buy them
Welcome from central Ohio.
You have stumbled on THE best place for advice/help.

What year?
Which harness? It's not all one big harness there are sections.
With more information a fanatic that is parting one out or possibly Cleveland power and performance (google it and call), but they will ask these questions.
Might be good idea to start a new thread to get attention.
 

·
One of the SoCal Nuts
Joined
·
28,016 Posts
Mice have gotten to my wiring. Insurance will pay for neww wiring harnesses. Where is a good place to buy them
Welcome to the Family from one of the SoCal Nuts!
You might also want to introduce yourself in the New Members Forum and consider adding some information in your profile so others will know if you are nearby. We are a friendly group and you might fins some willing helpers when you begin replacement , or finding other issues you need help with.
 

·
Registered
Joined
·
181 Posts
The lights in the switches for radio & messages have burned out. I removed the switch to find that the lights are part of a printed circuit board. I don't need the lights to operate. But wondered if any one has experienced this problem. I have replaced both switches twice. Same result of burn out lights. I did find Chevrolet did have the parts available back several years ago when I was having multiple electrical problems. Now? Nope.
 

·
One of the SoCal Nuts
Joined
·
28,016 Posts
I am new this site and have a electrical question for ED.
How can I contact him?
Go to the New Members Section and introduce yourself and ask him to get in touch with you. He should be able to send you a PM, which you cannot answer yet, but he can send you an email address or phone number that way if you ask politely.
Good luck and welcome.
 
101 - 120 of 125 Posts
Top