Chevy SSR Forum banner

121 - 125 of 125 Posts

·
Premium Member
Joined
·
42 Posts
Hey guys I NEED HELP. My hyd. system was leaking so I had the complete system replaced. Now the only way I can get my roof to go up or down is to manually lift the cover up and back then use the button to move the roof. I have had it to 2 different Chevy dealers and they don't have any idea what is wrong. I live in NW Florida near Pensacola and and need to find someone to work on it for me. I contacted Chevy customer service and they basically said tough SH__ !
Can anyone help me and tell me where to go to get it fixed. You can e-mail me at [email protected] or call me at (850) 684-1163
Thank You,
Biker ( Jack Kinney )
 

·
Premium Member
Joined
·
836 Posts
Hey guys I NEED HELP. My hyd. system was leaking so I had the complete system replaced. Now the only way I can get my roof to go up or down is to manually lift the cover up and back then use the button to move the roof. I have had it to 2 different Chevy dealers and they don't have any idea what is wrong. I live in NW Florida near Pensacola and and need to find someone to work on it for me. I contacted Chevy customer service and they basically said tough SH__ !
Can anyone help me and tell me where to go to get it fixed. You can e-mail me at [email protected] or call me at (850) 684-1163
Thank You,
Biker ( Jack Kinney )
Jack,
Recommend you move this issue to a new thread in the Technical section. You may not get the visibility you need on this issue on this thread.
Corrective action may be as simple as ensuring the micro-switches in the sidewall actuators are properly lubed (unstuck). You will likely get more questions before you get a good answer ... what year is your SSR (older SSR may have hinge-binding in the tonneau)? When you say "complete system replaced" ... what did that entail? Cylinders only? or Cylinders, plumbing, pump, etc? What happens when you press the "top down" button? Do you hear the pump running? Do you get a "timeout" message? Do the windows go down as expected? The more info you can provide, the more better response and recommendations you will get.
First thing though, recommend you move your question to a new thread for greater public visibility.
My best to you ...
Cheers, Carl
 

·
Premium Member
Joined
·
1,933 Posts
Hi All,

Quick question about the common fast-blinking turn signal issue with the new '05 R I recently had the privilege of acquiring. :smile2:

The previous owner, SeattleTerry, installed LEDs throughout which is cool. However it's suffering from the dreaded "fast blinker" syndrome. I asked Terry about it and he didn't recall it doing that and couldn't remember what-all had been done at this point.

So I did my research here and learned that probably all it needed was one of the recommended turn signal modules. (Even found Terry's original post about it here).

Terry kept immaculate records of everything that's ever been done to the R (bless his heart) and I found a receipt for an LM487 Electronic LED Flasher Module from LEDLight.com dated July 2010. Apparently one failed right away and they sent him another one. I'm assuming he installed it.

I also noted that Dicktator said that the LM487 took care of the issue on his R as well on this post.

I cannot find the post, but I recall reading a note from an employee of the original company that manufactures the turn signal module that there are "knock-offs" out there that are problematic and to get their genuine part if there's a problem.

Also, I found a receipt for a 6 Ohm LED Light Bulb Load Equalizer that Terry purchased in July of 2012.

Wondering if the turn signal module might be faulty, failing or if it's the load equalizer, or...

To add to the mix, if I turn the emergency flashers on, all of the lights including grille, tail and side blink normally. ???

Soooo... with all of that... I've been a "gear head" since my teens and have no problem digging into things like this, but I could use some troubleshooting advice from the experts here as to where to begin.

TIA!

P.S. To the mods, if this should be moved to another thread, no problem.
You probably should start your own thread --

I am not sure which LEDs he purchased - do you know if he actually installed the load equalizers, or just purchased. My money is on the flasher IF problem was not there before --- Load equalizers would be installed on each side - hard to believe BOTH would fail at same time. They are usually installed to front bulbs - so may be difficult to see without getting to the front bulbs. Hazard flashers (and modules) are designed to flash at same rate if there is is burnt out bulb. This way if in an accident and a bulb get broken the remaining bulbs flash correctly for others to see the car. T/S Flashers and modules are designed to change the flash rate with a change in current that usually occurs with a burnt out bulb (or LEDs) letting the operator know there is a malfunction. This is normally a separate logic module in the flasher module.

(Moderator: Quoted post has been posted in it's own thread)
 

·
BlueStreak
Joined
·
26,746 Posts
Hey guys I NEED HELP. My hyd. system was leaking so I had the complete system replaced. Now the only way I can get my roof to go up or down is to manually lift the cover up and back then use the button to move the roof. I have had it to 2 different Chevy dealers and they don't have any idea what is wrong. I live in NW Florida near Pensacola and and need to find someone to work on it for me. I contacted Chevy customer service and they basically said tough SH__ !
Can anyone help me and tell me where to go to get it fixed. You can e-mail me at [email protected] or call me at (850) 684-1163
Thank You,
Biker ( Jack Kinney )

Jack,
Recommend you move this issue to a new thread in the Technical section. You may not get the visibility you need on this issue on this thread.
Corrective action may be as simple as ensuring the micro-switches in the sidewall actuators are properly lubed (unstuck). You will likely get more questions before you get a good answer ... what year is your SSR (older SSR may have hinge-binding in the tonneau)? When you say "complete system replaced" ... what did that entail? Cylinders only? or Cylinders, plumbing, pump, etc? What happens when you press the "top down" button? Do you hear the pump running? Do you get a "timeout" message? Do the windows go down as expected? The more info you can provide, the more better response and recommendations you will get.
First thing though, recommend you move your question to a new thread for greater public visibility.
My best to you ...
Cheers, Carl

I agree that you need to start your own thread to get the attention you need.
 
121 - 125 of 125 Posts
Top