Chevy SSR Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
192 Posts
Discussion Starter · #1 ·
Has anyone replaced their radio antenae with an add-on option or anything else that works better than the original one? I have read threads about antenae problems before, but when I do a search, nothing comes up but the XM radio installation.
Any thoughts out there? There is some kind of adapter on ebay for about 10 bucks, but is it even worth the effort?? Thanks in advance.
Charley
 

·
Just a voyeur now...
Joined
·
154 Posts
I posted the following last month:
"Some time ago, there was a mention in this thread of a hidden antenna made for hot-rods by Golden RODtronics of Golden, CO. I ordered one, had it installed, and it seems to work really well. The main reason I did it was to be able to get rid of the stock antenna, which is very distracting to my number one passenger. I feel kind of bad asking this, after seeing all the trouble everyone is going through to get that thing working right, but does anyone know how to remove it from the windshield? I've tried eveything I could think of that wouldn't damage the glass, but no luck. Any ideas would be appreciated. Thanks"

The hidden antenna is shown at the botom of this page --> http://www.widecontact.com/rodtronics/electrical5.html#hiddenantenna
 

·
Registered
Joined
·
416 Posts
Questions to Bluish

Bluish said:
I posted the following last month:
"... but does anyone know how to remove it from the windshield? I've tried eveything I could think of that wouldn't damage the glass, but no luck..."
Have you tried simply scraping it off with a razor blade?

Also, where did you mount / install the "head" of the hidden antenna?
 

·
Just a voyeur now...
Joined
·
154 Posts
The head is mounted to the top of the windshield, behind the rear-view mirror. I had a car alarm/stereo shop do the installation, so I can't give you the gory details, but the antenna lead is routed across the inside top of the windshield over to where the stock connection is. I'm prejudiced, but to me it's not noticeable, and the radio reception is fine.

I did try a single-egde razor blade to remove the stock antenna. No luck at all. Maybe I was being too careful, but I don't want to do anything that'll leave permanent marks. I also tried alcohol and a couple of cleaning fluids.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top