Chevy SSR Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Hey folks recently purchased a 2004 I’ve noticed recently that it randomly won’t start then after. Few minutes it starts also noticed the temp gage goes goofy replaced ignition switch twice. I’m far from a electrical guy, any help would be awesome Thank Don !!
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
Yes they all sweep the other day I replaced the ignition switch for the second time started right up and temp gage worked as it should a few starts later wouldn’t start a gage was back to facing the floor !
 

·
Premium Member
Joined
·
2,584 Posts
When you say it won't start you need to be more specific.
Does the engine crank over and not fire ?
or does the starter not crank engine?
Do you notice if other warning lughts work normally? Example, Does check engine light come on when ign is switched to run.

Is there anything else that does not work when it won't start?
Have you had it scanned for codes?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
Does nothing like you’re starting it in drive all other lights a gages seem fine, did not scan
 

·
Premium Member
Joined
·
2,584 Posts
Some things to try

1. Try swapping underhood relays #43 starter relay with #42 Ignition relay -- realize this may change things if bad relay - it may now crank but not start as the faulty relay will now prevent fuel injectors and ignition coils from functioning.
2. When it won't start -- try holding key in crank position while wiggling gear shift or shift to neutral and try again. This might point to park - neutral switch beginning to fail or shifter bushing that is excessively loose and ready to fail that is not moving transmission range sensor properly every time. You may have to crawl under and just wiggle shift cable connection at transmission -- if it falls off -- weather or not it fixes the issue, better now then on the road.
3. Try to listen real close to underhood fuse box to see if relay #43 clicks as key is turned to start - or have some one place their finger on to feel for click, or place a regular compass next to relay and see if it moves when you try to crank engine. The magnetic field in relay if it is functioning will deflect the compass! ANY of you olde timers remember and or used this trick! -- problem is this has to be down when it acts up. This will provide clues on what to test next.
4. Get codes scanned - may not be any but worth a shot

More questions

1. After attempting to start and key is run position - temp gauge points straight down? all other gauges ok?
2. Whenever temp does not return to normal this is when it won't crank or does it not crank and then temp gauge acts up? When starting turn ign to run watch gauges sweep -- not positions and only then turn key to start (crank) then note gauges and weather the engine started - this will let us know if they maybe related.
3. You said you far from electrical guy can I assume that you don't have a voltmeter or test light? If you have either of these let me know results of previous suggestions and I will walk you through some additional tests
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7
Wow thanks,I know it’s not the shifter I run a towing service have felt with those issues many times, will get it scanned also one of the guys has a scanner, after that I’ll run thru the list and let you know how it goes, thanks for all the info !!
 
1 - 8 of 8 Posts
Top