Chevy SSR Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
I have a friend I met on a cruise that has an 06 Silver/black SSR. He has been having problems with his top. Sometimes it works and sometimes it doesn't and this has gone on for the past 6 months. I just had my fuse box repaired and wonder if this could be the same problem. The data I got from here and gave to my mechanic was spot on. He took out the fuse box and sure enough, the copper wire you guys stated broke apart with the lightest touch. Replaced it and I haven't had a problem since.

The guy I am sending this out for is not really computer literate but he will register and sign on.
If anyone has had this problem, I'd appreciate a response.

Thanks
Ron Raposa (Rabbydoo) with the Blue 06
 

·
Supporting SSR Hobbyist
Joined
·
10,007 Posts
Hey Ron,

The direct answer to your question is NO..... the fuse box repair has nothing to do with the top.... completely different.

Where are you (and the owner of the '06) located? We could possibly get some help to you and him in troubleshooting this.

Mike
 

·
SSR Pit Crew
Joined
·
12,537 Posts
WOW! Could be lots of things.

Hyd pump check valve releases after 30 seconds, ALL oil returns to tank, may be low on oil, press switch fills all pistons/hose, push again roof works.

T Latch switches may be sticking, what does DIC say?

Tighten 7mm bolts on rear fuse box.

Contacts on console may be dirty, like I said "lots of things".

Check out SSR How to Library, FREE, may give you some insight.

Link: https://onedrive.live.com/?id=3EF39D9F5ADCE5E5!853&cid=3EF39D9F5ADCE5E5

Dicktator
 

·
Premium Member
'06 FPR Smokin Asphalt; '04 Ulta Violet
Joined
·
4,234 Posts
Ron, I see you have been a member for a while, but like Mike said, you and your friend-----Consider going to "Tools" in the red banner, click on "User CP" go to "Your Profile" then click "Edit Your Details". Then, whenever you "post" it will show in the left column under your name, like the rest of us, and we will know where you are and what you drive. Then if you have a problem, someone close by might be able to help out. And Welcome to both of you from Forney Texas.

Nick & Kathy
 

·
Registered
Joined
·
55 Posts
Discussion Starter #5
Mike, I live in North Port Florida and the guy with the problem lives in Rotunda (Englewood) Florida. Glad to hear that the fuse box has nothing to do with it. I do see where some microswitches may be the problem. Electrical problems are really tough to find. He'll go a week or two with it working and then a week or so with it not working.

Thanks ]

Ron
 

·
Spirited driver!
Joined
·
1,426 Posts
Ron you and your friend are fortunate to live near some of the best and brightest SSR gurus around. Dicktator is in Clearwater. He and others around there could probably get it solved pretty quick. You might try reaching out to the south Florida group.
 

·
Supporting SSR Hobbyist
Joined
·
10,007 Posts
Mike, I live in North Port Florida and the guy with the problem lives in Rotunda (Englewood) Florida. Glad to hear that the fuse box has nothing to do with it. I do see where some microswitches may be the problem. Electrical problems are really tough to find. He'll go a week or two with it working and then a week or so with it not working.

Thanks ]

Ron
Ron,

It just takes some focused troubleshooting to solve it. This thing is not rocket science. Dick and the Florida gang will figure it out.

Mike
 

·
Registered
Joined
·
87 Posts
I had the same issue, sometimes it worked, others it didn’t. Sometimes it would come down and not go back up. Cleaned the connections at the switches at the back of the bed and problem solved, no issues since. It’s a simple, cheap attempt to fix and worked for me.
 
1 - 8 of 8 Posts
Top