Chevy SSR Forum banner

1 - 17 of 17 Posts
D

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I recently had this problem with my 2004 SSR. I get in and turn key and absolutely nothing. I called a tow truck and by the time they got there the engine cranked. This has now happened to me 3 times this week and everytime if I wait half hour it cranks up. I know its not the battery and I'm thinking its electrical or computer related. Has this happened to anyone else... I'm taking it to the Chevy dealer tomorrow but they don't seem to know much about SSR's.
 

·
SSR Pit Crew
2004 UV
Joined
·
9,315 Posts
where are you?

Hasn't happened to me but why don't you let us know what area you are in...someone may know of a dealership/tech that is more up-to-date on the :ssr issues and repair.
 

·
Premium Member
Joined
·
250 Posts
i had an 88 corvette that did the same thing..the battery goes open ..try to prove that to a doubting chevy dealer..a good load test at the dealer should fry the bad internal connection for good,,then you can get another ac delco battery on warranty
 

·
Registered
Joined
·
1,204 Posts
deba said:
I recently had this problem with my 2004 SSR. I get in and turn key and absolutely nothing. I called a tow truck and by the time they got there the engine cranked. This has now happened to me 3 times this week and everytime if I wait half hour it cranks up. I know its not the battery and I'm thinking its electrical or computer related. Has this happened to anyone else... I'm taking it to the Chevy dealer tomorrow but they don't seem to know much about SSR's.
sounds like the ignition switch as I change them quite alot in trailblazers for just this same problem and the SSR uses the same switch. I even keep a new switch in my SSR for just this reason. :seeya
 

·
Registered
Joined
·
221 Posts
I had the same problem and changing the ignition switch fixed it. :thumbs
 

·
Registered
Joined
·
254 Posts
I would bet on the ignition switch, too!

I had a similar problem, had the truck taken in for repairs and that was the problem. All too often, if a battery is bad it is always bad. Not usually bad, then good, then bad and so on. :rolleyes:
 

·
Registered
Joined
·
213 Posts
Bad ignition switch and check engine light

In my SSR, the check engine light came on and the truck began to have slow acceleration from a dead stop. Light would stay on and go off later in the day. The next day would come on again. In addition to these symptoms, sometimes I couldn't get the key out of the ignition. This went on for two weeks. Got new ignition switch and now no check engine light. :)
 

·
Premium Member
Joined
·
17,317 Posts
Have you tried staring at the key in the ignition and saying a few expletives?
 

·
Premium Member
Joined
·
1,890 Posts
won't start

I had the same trouble with my 04 Envoy , cure was Ignition Switch :seeya
 

·
Registered
Joined
·
349 Posts
It's the switch!

The vote is 5 for ignition switch and 3 for the bad battery. I add my vote for the ignition switch, based on your description of totally dead response. :thumbs
 

·
Premium Member
Joined
·
3,665 Posts
Peaches said:
The vote is 5 for ignition switch and 3 for the bad battery. I add my vote for the ignition switch, based on your description of totally dead response. :thumbs
And two for staring with expletives
 

·
Registered
Joined
·
76 Posts
Had the same problem

and it was the battery. Lights would come on and everything, but occasionally wouldn't crank. Then it would start perfectly the next 50 times, before faltering. Turns out that it was an intermittant open connection in the battery. Took many trips to the dealership for the fix. Finally, I had them swap the battery with my other vehicle and the problem (very intermittant) went with it. Once the battery was replaced by the dealership, the problem was gone.
 
1 - 17 of 17 Posts
Top