Chevy SSR Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hey members

I Am from the St.Louis Belleville area have had my 2004 SSR for about 3 weeks. Everything was working fine until yesterday. Went to work but when I was leaving truck wouldn’t start key wouldn’t come out ignition. Got a jump took to shop got a new battery drove off lot made a stop and something happened again. Now it back at shop. Has this happened to anyone else?
 

·
ONE OWNER !!!!
2004 Smokin' Asphalt #11150
Joined
·
44,562 Posts
Welcome From Western Pa !!!!!! :00000732: Try cleaning the ground where it attaches to the frame and check the ground wire for corrosion and replace if is bad. That's where I would start.
 

·
SSR Pit Crew
Joined
·
12,669 Posts
Sure will thanks, really appreciate the help. I love this truck!
My 04 only has 135,000 miles on it, 14yrs Old, like me, 83yrs old, I go to Doc a lot more now than I did when I was 20yrs old.

Dicktator

I like mine pretty well also.
 

Attachments

·
Registered
Joined
·
8 Posts
Discussion Starter #9
This one only has 26702 on it. That’s why I purchased it. Really did expect problems so soon. Hoping I can find someone to fix this one.
 

·
Registered
Joined
·
3,054 Posts
Rwhite welcome to the group. I am in the St Louis area as well. Used to work over in Belleville and would see quite a few SSRs at Auffenberg for sale at various times. What color truck do you have, let me know where about you are and we can be on the look out for each other. If I can lend a hand let me know.
 

·
SSR Pit Crew
Joined
·
12,669 Posts
This one only has 26702 on it. That’s why I purchased it. Really did expect problems so soon. Hoping I can find someone to fix this one.
If you fill out your profile so we know where you live, like what State, we can help you.

Dicktator
 

·
Premium Member
'06 FPR Smokin Asphalt; '04 Ulta Violet
Joined
·
4,393 Posts
Rwhite, Welcome from Forney Texas!!! You will discover that you have found the BEST FORUM ever!---Consider going to "Tools" in the red banner, click on "User CP" go to "Your Profile" then click "Edit Your Details". Then, whenever you "post" something, it will show in the left column under your name, like the rest of us, and we will know where you are and what you drive. Then if you have a problem, someone close by might be able to help out.

Nick & Kathy
 

·
Registered
Joined
·
8 Posts
Discussion Starter #15
Thanks Stlhotrod, I’m in the Swansea Shiloh area. Can always catch me at the Shiloh Arbys. The shop fixed it was the negative battery cable had corrosion. They replaced it. Thanks everyone appreciate it very much. Hope to meet u hot rod I have a 2004 black one also.
 

·
RedHotSSR
Joined
·
605 Posts
Heads UP

This one only has 26702 on it. That’s why I purchased it. Really did expect problems so soon. Hoping I can find someone to fix this one.
low MILAGE gives many NEW owners the notion that they will have many miles /years of trouble free driving. :crying: PLEASE take some time to read the Forum Tech. section, this will alert you to a few other issues you may want to address prior to experiencing an "On the Road" breakdown. e.g. Lower shift cable bushing MUST be replaced NOW. Contact "Simple Engineering" they can provide a list of the OEM parts you should consider replacing now. Oh and check the age of your tires. If more than 5 years old you may want to replace those also.

"Wishing you all the best and Long may you run":grin2:
 

·
Registered
Joined
·
210 Posts
Dead battery cause the alarm system to go into secure the vehicle. Nothing new for any new POS Car or Truck. Check & clean all grounds & reset the burglar alarm with fob or drivers door key. Clean battery box while the battery & cables connected to frame are loose. So many of the problems with SSR can be basic trouble shooting. The ignition switch is not always the problem. Check for a electrical drain too. Some thing is drawing power with ignition off. I found the radiator cooling fan shorted out. The neutral switch in console for hand brake can loose adjustment. My SSR would not allow head lights to turn on after setting hand brake. Access is through fuse access on passenger side. Heat fan relay behind glove box is another draw. The the old ABS mounted on frame next to catalytic converter can melt solder causing a short no trouble code.
 
1 - 19 of 19 Posts
Top