Chevy SSR Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
New to the site, but had my SSR since May. I put a new hydraulic top system in (TopHydraulics), finishing today, but much to my dread it does not work! I found this chat site hoping to find a solution from those who know. When I push the top down button, the windows roll down and I can hear the top unlock, but nothing else happens. I want to check fuse's but which ones and where. I have read about a RDM2 fuse but have no idea where it is.
Thanks for any help, I will look into past post's,
Everytime I walk into my garage, I can't believe I own this car!!
Ivo
 

·
Daily Driver
Joined
·
8,958 Posts
First go to tools up in the red band, click on user cp and fill in your detail over on the left. That way we'll know what year and where you are.

It hasn't worked since you rebuilt the hydraulics? So you didn't cycle it several times to purge the air from the lines and cylinders?

I suggest you go here and see what others have done.

And check out these instructions.
 

·
ONE OWNER !!!!
2004 Smokin' Asphalt
Joined
·
47,201 Posts
Welcome From Western Pa !!!!!!!! :00000732: As Bruce said go to Dicktators library folder 68 and go to the last page !!!!!
 

·
Premium Member
Joined
·
1,369 Posts
welcome
 

·
Registered
Joined
·
245 Posts
Can't help with your problem but welcome to SSRFanatics, I know you will get all the help available from experienced owners on this forum. I still chuckle inside every time I go out to the garage and confirm to myself that I actually own one of these gems. Welcome to the family.
 

·
Premium Member
Joined
·
38,462 Posts
Welcome from Canada! :cheers

I'll let the smart members help you, cause I don't know.

:black:
:purple:
Krazy Ed
 

·
Premium Member
Joined
·
4,679 Posts
Hello from So Cal.
You have come to the right place for all things SSR.
Someone will be along to help, just be patient.
 

·
Premium Member
'06 FPR Smokin Asphalt; '04 Ulta Violet
Joined
·
4,612 Posts
Ivo, Welcome from Forney Texas!!! You will discover that you have found the BEST FORUM ever!---Do like xoxoxoBruce said---Go to "Tools" in the red banner, click on "User CP" go to "Your Profile" then click "Edit Your Details". Then, whenever you "post" something, it will show in the left column under your name, like the rest of us, and we will know where you are and what you drive. Then if you have a problem, someone close by might be able to help out.

Nick & Kathy
 

·
BAD BOW TIE
Joined
·
11,385 Posts
A big hearty welcome from Sunny Sturgis South Dakota!!!
 

·
Genuinely SSR Obsessed
Joined
·
8,551 Posts
A Big Ole Howdy from Houston Texas, Ivo. - :seeya

Say, your first name wouldn't be "Tommy", now would it? - :surprise:



===============
David :black:
2018-09-25-06-06-55--876129035.jpeg - October 31st is almost here!!
 

·
Registered
Joined
·
95 Posts
Hello from Central Florida. Just a wild guess, not enough oil in reservoir. Check Dick's guide to the Universe, or the list of repairs available in the repair guide.
 

·
Premium Member
Joined
·
1,464 Posts
Welcome from northeast Texas I’m not a mechanic but in Dallas November 11th there would be smart people could help
 

·
Slingshot Rules!
Joined
·
75,334 Posts
WELCOME, Ivo . . . from Southern Arizona.

! :cheers ! :00000732: ! :cheers ! :00000732: ! :cheers !​
 
1 - 20 of 20 Posts
Top